Roon Optimized Core kit stuck on “Enabling Combo384 Amanero” [Solved - Updated Roon Version]

Roon Optimized Core Kit installed successfully…… but stuck on “Enabling Combo384 Amanero”

The Core Kit is installed and running on a NUC7i7BNH (BIOS 0065) with 8GBRAM/ 256GB SDD boot/ 2TB SDD internal storage.

USB output connected directly from NUC to an Audio-gd R2R-1 DAC (combo 384 Amanero) via USB cable.

Roon control is working on the network from a Samsung tablet and I can add FLAC files to the internal NUC storage SDD successfully.

The Roon Core Kit recognizes the Amanero as “Connected to Core Directly” but when the “Enable” button is activated it stays stuck on “Enabling…” like it can’t find a driver for Amanero.

Please advise… thanks…billj

Try restarting the rock by doing a shutdown and reboot

Hello @Bill_Jacobsen,

Thanks for contacting support, I’d be happy to take a look over this issue with you. Can you please confirm that the Amanero DAC is powered on and connected before attempting to start playback? Can you also confirm that you have the correct USB source selected on it from the front panel as well? I would recommend that you install the driver for it as well, but I have been looking over that website and I see no links to download drivers, did you by any chance receive a CD with the DAC that could contain the drivers? Please let me know when possible.


Hi Wizardofoz…if by shutdown and reboot you mean power off and restart or a clt-alt-del then the system rebooted but no change to the result… I’m thinking that I don’t have the driver…will work with Noris from Roon support to try and work throught the issue…thanks for your input…billj

Hi Noris … yes to all your question…DAC is on, connected before playback (can’t playback as it is not enabled), correct USB source selected.

Other output devices like my AirPlay Denon receiver work fine.

Regarding drivers…I only have the Windows drivers that you download from the Audio-gd site…they worked fine when I was running Roon on a windows laptop OS.

Not sure if the Linux drivers for Amanero are built-in to your Roon Core kit or how to install them if they are not.

Thanks for your help and patience…billj

screen shoot…

Hello @Bill_Jacobsen,

Thank you for your screenshot and confirming that the DAC is on and has the correct input selected. I asked my colleagues and they confirmed that most DACs do not supply Linux drivers (such as ones for ROCK). The next step here is for me to enable diagnostics mode on your account, which I have just done so.

What this action will do is the next time your ROCK is active, an error report will automatically be generated and uploaded to our servers for analysis. I have gone ahead and started a case regarding your issue with our QA team and they will review the logs to see if we can narrow down what exactly is going wrong here. I appreciate your patience while QA has a chance to review your case and I will be in touch with their findings after they complete their report and pass it over to me.


Hi Noris,

I’ve “disabled” and tried to re-enable the Amanero output… so hopefully an error report has been generated.

Be a bummer if Linux drivers are not available/compatible for Amanero in the Core kit… as I was trying to do away with using a windows laptop as core and set up a true dedicated audio server with the NUC.

thanks for keeping me informed… billj

Hi Noris…Please note the following from the Audio-gd web site…

Amanero Combo 384 USB Interface (With official license)
Supported Sample Rates :
44.1Khz 48Khz 88.2Khz 96Khz 176.4Khz 192Khz 352.8Khz 384Khz
Output Format :
I2S 32bit or DSD64,DSD128 (Native mode and DOP mode) - On Windows DSD256,DSD512 too
Supported systems:
NO Drivers needed for Mac OSX 10.6+ and Linux with UAC2 compliant kernel.
KS/Wasapi/WDM/ASIO Drivers for MS OS XP to Win10 32-64bit included at no fee.
Apple ISO (Iphone and Ipad through camera kit )
Andriod (Support USB2.0)

Please note:
(176.4kHz, 192kHz, 352kHz,384kHz and DSD are only available in USB audio class 2.0 and 3.0 / High speed mode . USB audio class 1.0 / 1.1 support up to 96K /24bit )

  The Amanero had very low jitter present. From the HiFiDuino report, the Phase Jitter 0.04~2.41ps (10Hz~1MHz), Total Phase Jitter (RMS) 2.42ps . 

More inform :

Hello @Bill_Jacobsen,

Thank you for providing that information, I have attached it to your case with QA, waiting for their report will be the best next step forward here. I will be sure to let you know if what they say regarding that UAC2 kernel driver but unfortunately the logs need to be fully analyzed before I can recommend any additional troubleshooting.


Hi Noris…Update: Solved?
As downloaded and installed today the Core Kit was running version 1.4 of Roon. (from the “about” diaglog)
An update notice to version 1.5 was noticed in the “about” dialog.
When updated to version 1.5 the Core Kit accepted and enabled the Combo384 Amanero interface.
So that problem appears to be solved.

Hello @Bill_Jacobsen,

Glad to hear that updating the ROCK has solved the issue and your DAC is now working. Let us know if you run into any further issues but if not, hope you have a great day!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.