Roon OS 1.0 Build 253/254 - no HDMI audio out on Zotac CI331 (MOCK)?

Hi @Burkhardt_Petermann ,

Full of anticipation I installed ROCK with UEFI support (ROON OS 1.0 build 253) on the ZBOX CI331. However it doesn’t support the HDMI interface. Is there something I can do to enable it?


OK, back to Windows 11 then. It’s a shame, I really liked the small footprint + easy and quick install of ROON OS.

I’m not sure if it was working for you before Build 253, but with a NUC, I think you need to enable HDMI audio in the BIOS for it to show up in Roon.

I haven’t tried any build before Build 253 because the bios only supports UEFI. However a fellow Roon user has the same mini pc (not nuc) with an older bios that supports BIOS + HDMI with ROON OS 1.0 Build 227.

In Windows it looks like this. I assume if Windows is able to use the HDMI output then ROCK should be able to use the HDMI output too. It is updated using the Intel UHD Graphics driver. (

Roon OS 1.0 only uses HDMI for (multichannel) audio - it does not use the video channel.

This may possibly be introduced with Roon OS 2.0 - whenever that finally arrives…

That’s what I’m missing. There’s no HDMI audio in ROON OS 1.0 build 253/254. I tried DietPi too, it doesn’t find HDMI audio either.
It should be possible, it’s just Intel HD Audio (Digital 8 Channel Audio Loss-less Bitstream via HDMI, according to the specifications)

Ah, so this is a MOCK, and not a supported NUC then. Sorry, but this is an AYOR situation… No guarantees that what worked earlier will continue to work with newer releases.

I understand this is a AYOR situation, but hoped someone could help me or give me some more insight. I don’t think that it’s specific to ROCK (ROON OS). Any Linux distribution I tried (Ubuntu, DietPi) doesn’t recognize the HDMI audio interface. (HDMI video works as expected.)