Roon perfectly running, but the NUC is not pingable

Roon Core Machine

Intel core i7 (8th generation for the new one).

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

On internal drive (cca 130 000 tracks).
On my NAS (cca 30 000).

Description of Issue

Hi everybody!

I just changed my older NUC to a new one, purchased second hand.

My issue is that the new device appears as not pingable, and cannot be seen on my computer.

But it’s perfectly running, and has normally access to Qobuz,

I just switched back to my older machine : pingable, seen from my computer, etc., which my new one is not.

What can I do ?

Thanks for helping me.

[Moderator edit: ROCK → NUC]

Attach a monitor at boot time and post a picture of the screen.

Bu pingable, do you mean you can’t get on the GUI? If you can get on the GUI, screen print that screen also.

How is the ROCK attached to your sound system. It sounds like, rather than thru the network, you are using USB? Although, it must have a network connection if you can use Qobuz. Dunno.

I’m guessing the new NUC hasn’t got the ping service enabled for some reason.

1 Like

Are you pinging the correct IP address? It will be different to your old NUC.

If you are pinging from a Windows PC, I have seen antivirus and Windows Network Discovery settings cause this sort of ‘invisibility’ problem, in the name of Security.

I am not familiar with NUC BIOS settings, but as you bought the NUC used it may have some security feature enabled in the BIOS causing this issue?

Thanks all of you for these sound advices.
Attaching the device to a monitor, at boot time appeared the name of the precedent owner. So I guess that it’s probably protected by a password I don’t know.
To answer some questions, yes I was pinging the new IP address and the Rock is connected via Ethernet - not through USB. And “not pingable” is also said on the scanner I use “no route to host”.
I’ll resume searching as soon as the precedent owner has replied to my request.
All the best,


The last time I had strange network issues like that it was the router that needed a reboot. Have you done that?

In the pasttime once I had the issue, that my printer did not work on one port of my switch but on another port (of the same switch - NOT router, JUST switch) => reboot the network gear is something which might help (in very rare situations, but why not trying, works fast and costs nothing)

Thanks. But unfortunately rebooting the router doesn’t help. And according to IP Network scanner, 2 active ports : 3483 (slim-devices) and 9000 (cslistener), whereas according to iNet Network scanner: 3389 MS WBT Server (?)

You can ping both the IP number of ROCK as well as the hostname ROCK (or whatever you’ve called your ROCK NUC). If you cannot, then something on your network is blocking it, not the ROCK NUC itself.

Agreed, as ROCK is locked down it is unlikely to be anything but a network issue or an issue on the PC you are trying to ‘see’ ROCK from. This has been asked before but can you access the ROCK web page on that PC? If so, post it.
What exactly is meant by ‘not seen’?

That doesn’t sound like the behaviour of a ROCK installation? Can you post a photo of the monitor display?

Dear all,
Thanks for your concern, thanks for your advices. I think the issue is solved now.
What happened is that the past owner had blocked access to the Roon Core from another computer than his own. So I could play music (through Roon, from my NAS…) on this device, but I could not reach the Core from my computer : it was said “not pingable“ on the IP Network Scanners I use, and I could not have access to it from my desktop.
I just attached a monitor, a keyboard and a mouse to the core, and I tried to understand what was happening. Things were complicated by the facts that 1. as a Mac owner, I’m not comfortable with Windows, 2. the precedent owner was German, and I’m not comfortable with this language… But everything’s OK now, thanks a lot once more !
All the best,

1 Like

This must be NUC running Windows and Roon Core and therefor it’s not a ROCK installation.
I’m adjusting the topics title to reflect.

You put your finger on it, Carl. And I was not aware of that.
Would that be any benefit switching to ROCK, and would that be technically difficult ? Thanks anyway for making me understand the issue.

If you aren’t used to windows it might be better as once past the initial install you can just forget about it.

I agree with @ged_hickman1, though there is a leaning curve with ROCK to install it (the forum would of cause be on hand to support you).

However, critically your NUC needs to be compatible with ROCK …

Checkout this page … specifically the “More about ROCK’s hardware support…” section…

If your NUC (what version is it?) is not listed (it may be too new) just hang tight … at some point Roon will update RoonOS (that ROCK runs on).

There has been some discussion on a Roon OS update and new functionality but don’t expect to see a timeframe for it’s release (Roon don’t do that).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.