Roon: played_empty_swim

On the discover page, I sometimes get the error Roon:played_empty_swim, when I select play artist. Looks like it is mostly Tidal content when this appears.

Thanks – this looks like a bug. We’re on it.

@mike, Any progress updates on this issue?

I chose a guy by the name of Kevin Chalfant (located through album credits) and pressed play. Roon returned ‘Roon: played_empty_swim’

I have no albums by this artist, but he does appear on a few albums in my collection - should playback not be for tracks in my collection?

Yeah, we have a ticket open for this, and sadly have not gotten this fixed yet :persevere: If I’m remembering correctly, this happens when a performer has no main albums in your library – just appearances.

This will be fixed when we kick off work on a number of planned fixes for Radio in the near future. This should happen after a big round of metadata work we’re kicking off now focusing on equivalence issues specifically, which I briefly mentioned yesterday.

I am getting this error ‘played_empty_swim’ too with Roon 1.1 build 99. But perhaps under slightly different circumstances: I’ve just played all of my ‘favorite tracks’ (by going to tracks and filter on favorite). After all of them have played, I unsuccessfully try to play them again by pressing the ‘Play All’ button. This is when I get the error.

Good catch @Nepherte – I can reproduce this and I’ve opened up another bug report in our tracker.


Latest version, was playing an artist–Andrew Hill–then tried to switch to another artist–Rudy Van Gelder (yes, he was a recording engineer, but it’s a choice). I clicked on “play artist,” then did the usual click, click, click, and got the error.

Is a fix for this issue going to be included in 1.2? It’s becoming annoying having to restart Roon everytime I want to restart playing all my favorite tracks :slight_smile:

Yes, this is fixed for 1.2 – much simpler fix than what we have planned for Radio in the future. Thanks for your patience @Nepherte!

I’m a new (trial) user - 1.2 is a great app, but the “Roon:played_empty_swim” bug from a year ago is still around - I see the error frequently when attempting to start the Radio.

What files are you playing when this happens. Haven’t seen it in a very long time.

I have a couple of Tidal playlists. If I select any track in one of them, and click the Radio button, I get the “Roon: played_empty_swim” error message. Radio works OK from tracks in my local library - great feature, aside from the Tidal issue.

Hi Richard,

Seems to be a bug. Good catch. The Radio option is not available when selecting a song on a Tidal album that isn’t in your library. It should be the same with a Tidal Playlist.

Let’s let @mike or @brian know.

Cheers, Greg

Hi @Mike, did this fix get rolled out in 1.2 … If so it seems there’s another manifestation.

Apparently it’s still not fixed in 1.2, as I see the error frequently.

There were some straightforward cases when you might have seen this error which were fixed for 1.2, but more substantive changes are planned for later this year when we do some work on the Radio algorithm.

I just tried a few cases in my own library that I know used to have this issue, and they all worked as I expected. If you can give me a little more information about what you were trying to play, I can take a look at what’s going on here.

Thanks for the report!

It works fine on mine now.
All of my issues have been fixed in 1.2
Crashes no longer happen every hour.
Fixing split albums works without affecting other albums.
Happy bunny.

Perhaps I’m expecting more than is there?
I have a couple of Tidal playlists. If I select any track in one of them, and click the Radio button, I get the “Roon: played_empty_swim” error message.

Ah, ok. Thanks, that makes more sense.

We are planning to expand Roon’s Radio feature to include TIDAL content, but right now the feature only works on content in your library. That means that when a TIDAL album has been added to your library it works just like your local files – it can be used to start Radio and it will be included in Radio.

We’re hoping to make these changes soon but for now you’ll see that when you click TIDAL albums that aren’t in your library you only get a Play button, which is the expected behavior for now. The bug here is that we’re showing the Radio button on TIDAL playlists content that doesn’t yet support it. We’ll get that fixed and update everyone as we improve Radio!

Thanks for the report @Richard_Zehr!