Roon player losing album covers

Core Machine (Windows 10/ Roon 1.7 (Build 505)

My Roon Windows player in my office will lose all album arts 10 - 15 minutes after starting to play. No problem with sound or other functionalities such as accessing Tidal, so I assume it is not blocked by antivirus or malware product. Sample below:

The only way to get around this is to restart Roon, but soon after the problem will reappear again. I have also tried clearing image cache but made no difference.

Can Roon technical staff advise please? I have no problem with my Windows player at home so it is not account related.


Hi Raymond,

You might try clearing the Image Cache and see if that improves things. Go to Settings - Setup there is an option to Clear Image Cache.

1 Like

Thanks Daniel, but as mentioned in my message, I already tried that. :frowning:

Oh, sorry Raymond. I missed that.

1 Like

Office? Maybe its your DNS settings

I see. Curious to know why DNS setting would affect album art, especially when they showed up but only to disappear 15, 20 minutes into play? Also all album arts are gone, including local ripped CD, not just those from say Tidal, so I do not understand why DNS setting would affect even local album arts.

Any advice is appreciated.


Hi @Raymond_Ho,

When this happens on the Windows device, do you see the same behavior from other remotes?

Hi @dylan, the database is on the same computer, so I’m not using any remote. Not sure if I’ve answered your question properly.

Because network related things can get messed up if dns settings are incorrect. Roon pulls the images and also tidal stuff from the internet so if dns is not quite right things can get lost.

Thanks for replying but what I don’t understand is if the DNS settings are preventing my Roon to access album art online, why would it allow access at the beginning and not after listening for ten to twenty minutes, also, why would DNS settings affect my local album art display?

The comment was more related to your being in a office situation and perhaps restricted internet via firewalls etc

Thanks but our firewall has no such restriction on images or other access, including porn :smile:

Thanks for helping anyway.

Hi @Raymond_Ho,

If you have another device that you could install Roon on to use as a remote, even temporarily, that would be a good data point. This type of issue can stem from a couple locations — The network, as wizardofoz suggested, or an issue specific to the device using the UI. If the same behavior happens on another remote, it’s likely that this is networking related. If it works okay on the remote, we know it’s specific to that machine.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.