Roon player on PC via HDMI. fail to play 7.1 but 5.1 works

Core Machine (Operating system/System info/Roon build number)

i7 32GB RAM, Files live on this machine
Windows 2012 Server
Roon: 100600416 1.6 (build 416) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hardwired LAN. Core and Files are on the same machine

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mini PC with HDMI output directly connected to a Denon AVR-2313

Description Of Issue

Bit of a strange issue.
I have a mini fanless PC which has a HDMI output and is running windows 10.
As I wanted to try multi channel audio with Roon I thought I would set this up.
So the Mini PC does directly into the receiver.

I installed roon, and gave it a go. I set it’s output to 192khz, 24bit 7.1
It all seemed to work out at the start (The amp said it was getting 7.1 multi channel).
But playback would stop after a few seconds and I was getting warning about performance.

I noticed the disk was at 100% utilization and realised that as I hadn’t used it for months, it was doing multiple windows updates.

So after about 12 hours and 4 reboots the machine settled down.

But now, roon didn’t work. As soon as I pressed play, it would say for a split second playing then stop immediately (like it thought it had just played but it didn’t)

I try changing options, and found that it did work when I set the output device to 5.1 (or 2.0).
When I set it it to 5.1 the amp simply said Multi In (not 7.1 Multi like it did before the windows updates)

So now there are no performance issues, it plays very smoothly but I am limited to 5.1, when I would really like to be able to play 7.1

Any idea on how to fix this one?

I have a Denon 3808 AVR. I found that the maximum sample rate it would accept in 7.1 was 96kHz. Try these settings:

Hi Geoff,
Thanks for the tip but sadly, it didn’t work.
I tried 96khz and 44khz and it still had the play then instantly stop behaviour.
On 5.1, I can set it to 192khz and it downsamples to 176.4khz and sends that to the Denon and I can hear it fine…

I think there might be audio device settings in Windows that need to be set for 7.1. Did you check there?

Hi @gwpt,

Can you share a screenshot of Device Setup for this zone as well as a screenshot of the signal path when playing 5.1 content?


Here’s the signal path:
Here’s the normal device setting:
The Advanced setting:
And the advanced showing all options available:

This is what appears on the display of my amp when playing 5.1:

For comparison, this is what the amp displays when I play a 7.1 movie from my apple TV:
This is also what roon used to display before the windows update

And here are some pics (please excuse the poor quality) of the audio device on the PC (It is appearing as the Denon AVR, I assume as the HDMI out is connected directly into the AVR)

Main Audio properties:
Supported Formats:
Levels Properites:
Balance Properties:

That’s all the info I could get!

I notice that in your device setup, you haven’t got “Exclusive mode” switched on, so the audio path is going through the Windows OS mixer. Try turning Exclusive mode on, and see what difference that makes?

HI Geoff,
I just tried that, and the behaviour was the same (I needed to disable MQA to get anything to work).
The only difference was this time there was a pop up that said “Failed to initialize the audio device”

i am confused… after changing all the settings around endlessly (including trying various sounds modes on my amp), it suddenly seems to work in 7.1…
even though thr settings are the same as the ones i tried before.
oh well, i won’t complain but I am curious why it now works! :slight_smile:

It may have been caused by a different sequence of powering up your equipment? HDMI handshakes are notorious for causing odd things to happen - particularly if you’ve got a chain of devices, e.g. Roon -> AVR -> TV.

1 Like

Argh ok. yes, it does seem like it could be that, as the setting are the same as when I first posted this message! of course, I have no idea what the sequence was as I tried so many things… Oh well, I’ll never reboot that machine again then :wink:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.