Roon playing through RME adi 2 dac

Hi all of you ROON Lovers,
My system: Mac Mini 2020 Intel processor, OS Big Sur; Ethernet connection, WiFi disabled.
RME ADI 2 DAC via usb 2 connected with Mac Mini
This dac connected to
Preamplifier, Amplifier, loudspeakers
Mac Mini via HDMI connected to PANASONIC TV screen in Living Room

ROON is installed on Mac Mini as ROONSERVER and my iPad is used as Remote.
My question.
In the Audio MIDI Window from the Mac Mini I see
ADI 2 DAC
Internal output
PANASONIC
and a special driver Soundflower which I have installed because it is transparant and let the driver of the dac trough.
What I want: the music must go through the Adi dac because it can handle dsd 250 and has a very good internal clock. So I choose the Adi dac to handle this. The Mac accept this choice and I see a little symbol to demonstrate my choice.
But when I start playing a music track the Audio MIDI shows that the computer makes a switch and this symbol goes to HDMI or Internal speakers or Soundflower. Soundflower is Oké for me because it is transparant and I can see on the dac display that dsd is chosen. The sound is very good.
I don’t understand why this switch and not stay with the adi dac with its very good internal clock.
Any idea?
Michel G.

Sounds like you added the wrong output on the Mac to Roon so it’s using HDMI.

In Audio section in Roon settings. Do you see the RME showing up as connected to the Mac? If you have HDMi connected to a device as well Roon should also see that and you might have added that

It should show up as connected to the core like this.

If it doesn’t then Roon is not seeing the DAC, perhaps Soundflower has exclusive access and is stopping Roon from seeing it. I would take Soundflower out of the loop and see if it works.

Thank you Simon,
On the Mac Mini I have only installed ROONSERVER. When I on the iPad open in Settings the Audio I see the Adi dac as unidentified.
But when I open this Device I see the settings that are correct.

Have you enabled it in the UI? Can you choose it as a Zone in Roons remote interface and it’s still going via HDMi? If so as I recommended remove Soundflower and check midi settings as its likely over ridding some default behaviour. I

Yes, but alas Roon has not RME Adi dac in his database. RME has published drivers for the ADI 2 on the Mac and they are installed with succes. In the Audio MIDI ADI is recognized with the right properties.
I have installed Soundflower because, if Soundflower is removed, HDMI is chosen and that is not what I want. With Soundflower the properties of The ADI Dac stay intact. So far so good. In the Remote app on the iPad I have chosen a Zone with the ADI as device. Nevertheless in the Audio MIDI screen I see when music starts playing the loudspeaker symbol switch from the Adi to Soundflower. Not detrimental for the sound, but this switching I don’t understand, as I said before.
Thanks, michel

I’m not using Mac, but Linux operating system. RME drivers are not required and my setup looks like this:
Clip0003


It matters not if its in Roons database or not, it nothing to do with what its doing. All it means is Roon has not been sent the DAC by RME to get Roon tested status. Doesn’t mean it won’t work as intended. I don’t understand really what Soundflower Is or the midi interface in MaCos. Mine just plugs in to my Rock server and works and the same on my windows pc, no issues with Roon.

Soundflower is a virtual audio output device.
From the website of Rogue:
“Soundflower is an open source kernel extension for MacOS, designed to create a virtual audio output device that can also act as an input.”

Hi @Michel_Goldsteen,

Does the DAC work if you try to play directly to it (with Soundflower disabled)?

It is unclear if the Adi Dac works on its self. When I disable Soundflower I see that one of the other ‘players’ get a symbol that it is active. The other are HDMI and the sound system of the Mac mini.
What I have done: I created a combi of Soundflower + Adi Dac. On the display of the Adi Dac I can read that it is the active player, at least I suppose so. When I chose in ROON upsampling to DSD 64 ( by the dsd function), I can see that upsampling on the display of Adi Dac.
Thank you

Let’s try this…

Don’t group SoundFlower and the ADI dac in Audio Midi setup.

In Roon’s device setup, leave the ADI in exclusive mode, but switch the volume control over to Fixed Volume.

(and to reassure you, if you’re using USB, SoundFlower or not, you’re using the DAC’s clock)

Thank you Xekomi,
A reassuring message from you. Indeed for me was the question which clock is used. Because the clock of the Adi 2 fs dac is fantastic, I am glad that Adi’s clock is the one in use.
I will try the settings you recommend and will see what will be done by the Mac Mini.
Thank you, michel

1 Like

If your RME ADI-2 got fs in the name, it always uses the steady clock. Get the details from here:

Hi Peter,
Thank you. Yes I know that RME ADI 2 FS has this excellent clock to suppress jitter. My doubt was that in the Audio MIDI window Soundflower, the transparant driver, one sees Clock Standard . But in reality the clock used must be the ADI 2 FS Clock. right?
By the way, RME ADI Dac is for a very reasonable price the best Dac I have used, with whistles and bells. And with a very instructive Forum of users.
Happy listening, Michel

Using this with Roon sounds like a terrible idea. It’s uncommon for a USB DAC to require installation of manufacturer’s drivers to work with macOS. I just checked the manual for the RME ADI 2, and it does not appear that a driver is required.

@Michel_Goldsteen - where you able to configure your DAC in Roon’s Audio Settings? Don’t use “System Output”. Definitely don’t use audio routing software like Soundflower or Rogue Amoeba’s SoundSource with Roon. There’s no need, and they can create problems.

1 Like

Thank you David. I did an uninstall with a script that was together with the install of Soundflower. And restarted the Mac Mini. Indeed, in Audio MIDI window Soundflower was gone.
Then I selected the ADI DAC device for sound output. And guess what:
The PANASONIC TV, that is connected to the Mac Mini as monitor, got the little loudspeaker symbol as the active Device for sound output. But nevertheless when I look at the display of the ADI DAC I see that the upsampling I realized with ROON’s DSP to DSD 64 was chosen in the ADI DAC. And the sound is perfect. The only thing is, I can not understand that in the Audio MIDI window the ADI Device has not the loudspeaker symbol as prove that this is the active Device.
Thanks,Michel

Don’t select your ADI DAC in MIDI settings. You’ll need to enable it as an output in Roon’s Audio Settings and then select the ADI DAC as the active zone for playback, again in Roon. Not in macOS Sound or MIDI settings.

1 Like

Thank you again, David. I have done according to your instruction. I use another music player Audirvana to confer it with ROON. I follow the same way as you advise. In Audirvana one can select the ADI DAC in the settings and it works.
It seems that ROON and Audirvana choose exclusive the ADI DAC as Device and that the Mac then seeks for another sound output (without using it as long as ROON or Audirvana is active).
Thanks for your help, I appreciate that very much,
Michel

1 Like

Guess what! With ROON SERVER playing exclusive using the sound output from the ADI DAC, as advised for the best results, sound is not possible in Safari playing a video. Also in other applications as YouTube and Vimeo. The SoundFlower Device I had removed. But with SoundFlower again installed as a transparant Sound Device, the sound in Safari came back.
Conclusion: SoundFlower for me is a Device that I will use. I understand now that it has no adverse effects on the sound of music.
Thank you all for the help and advise I have got for my problem and question,
Happy listening, michel

Hi @Michel_Goldsteen

I’m using an ADI-2 FS DAC (V2) with macOS.

There’s no need to use Soundflower to have Safari audio playing to ADI-2 DAC.

Just choose your ADI-2 DAC here to play Safari audio

image