Roon plug-in for Elgato Stream Deck released

Confirmed. This is not working in build 880. Once the software updated it just stopped responding, and trying to reconnect to the Roon core, the core does not see the extension authorization request.

I sure hope we can get this sorted out.

1 Like

This appears to be an issue with the ports being used for Roon API. It seems like they were moved?

Not sure how helpful it is, but I tried using these new ports and still no dice, so. Can’t say if that’s the main cause or not. I have no idea why Roon doesn’t just tell you what ports are being used for the program somewhere in the About section…

I was able to fix it by specifying Port 9300 in the Elgato configuration app.

Why Roon doesn’t call out if it is going to change things and make it easy I’m not sure. I would think that Roon would include all extension developers in their beta testing group or have it cleared through the developers. But perhaps I am misunderstanding why this happened.

Anyway, at least it is not a complex fix. Happy holidays, and much music listening, to all!

EDIT: for clarity, if that port number doesn’t work, you can find the port your Roon is using by looking at DISPLAYS under SETTINGS. That link includes the port.

3 Likes

Thank you so much. I was trying every port I could and nothing was working.

Hopefully the dev reads this thread and adjusts their documentation/plugin default port, as well as your comment about where to find it, so this doesn’t happen to other people.

That’s strange, my config doesn’t use 9300 at all.
I’ve been able to narrow down the ports my setup uses to tcp 8008,8009,9330:9339,9200 and udp 9003

Hopefully Roon doesn’t pull some different port numbers out of it’s hat with every new release…

Edit: I don’t use this plugin, but thought this info might help others

This post explains why the port number shouldn’t be hard coded: Roon Api on Build 880: Connection refused error :( - #3 by brian :slightly_smiling_face:

1 Like

Thanks for all the troubleshooting everyone - I haven’t time to work on this plug-in for a long time. I wrote it originally for my son, but he’s moved out since then, I don’t actually even have a Streamdeck in the house anymore which has made it even less of a priority.

With that being said, if there’s anyone who wants to take ownership of the project please let me know. We can then coordinate with Elgato to switch out the plug-in in the store to the newly owned version. In the meantime:

  • I’ve made the code repository public in case there’s a need for anyone to tweak or build a custom version: GitHub - docBliny/streamdeck-roon: Roon controller for Elgato Stream Deck
  • If I remember correctly, the code doesn’t use autodetection of the port because of the limitations imposed by effectively running in a browser sandbox for Streamdeck. I haven’t checked if this has changed, but that is likely still to be a limitation (unless you write custom code to try connections on the allocated port range or find another option to the discovery process).

//Tomi B.

Excellent James, thanks for that.I now know where to look in the future!

Hi all

i also can’t seem to get it to work since the latest roon build, if anyone has a solution of this would be great to discuss here

best

Z

Hi @zeltak_b

The problem is that the Roon Core API port is now dynamic. For example, on my ROCK Core which I just updated to build 884, the port is now 9330. However, thanks to @James_I, it is easy to find out the port.

If it has changed, you need first to set the port for one Roon button in Configure Stream Deck for Roon. And then go to Roon Settings → Extensions where you should see Tomi Blinnikka’s extension listed and can authorise it.

Your Stream Deck should then be back to normal

david

PS The good news is that my port did not change between build 882 and 884, though it did change between 880 and 882 when i had the same problem as you are having.

wow @David_Small thx so much, my issue was that i didn’t re-enable it after the port change so thought it didn’t work. after doing so it works life a charm

really appreciate your kind help

best

Z

Just want to say that I was stuck until I found @David_Small 's comment with the updated port. I also appreciate your explanation of how to find the port. I’m sure this will come in handy for other needs.

Thank you!

Thank you. I thought it would be useful to know about how to find the current port (thanks to @James_I). I was surprised how much I missed the Stream Deck Roon extension when it wasn’t working. For example, if a call comes in I can pause the music just by pressing a button, rather than having to scramble to open the Roon app. Continuing thanks to @Tomi_Blinnikka for creating it.

david

Thank you @David_Small for posting this fix. Very much appreciated. I just love this Stream Deck extension, and it’s great to get it working again. Thanks again to @Tomi_Blinnikka for creating it. It’s just fantastic.

Does the plugin for stream deck update automatically, mine is constantly dropping. I have to go into stream deck click a button with roon where states roon core is not connected, click connect then it works again.

Its not a port thing persay.

Hi @Gareth_Irwin I use the Roon plugin every day and haven’t noticed any particular problems since the port change issue in December 2021. I think I’ve noticed the Roon buttons going grey from time to time, usually when something changes, such as updating the Rock Core or updating the Stream Deck software but usually it re-establishes communications without having to do anything much. I have one button to Play a Selected Radio Station which is useful for checking. Current version of plugin is [1.0.7] - 2020-08-07

Hi all

was wondering if in the play related items there could be an option to launch bookmark? currently I only seem options for playlists and tags

thx a bunch!

Z

Hey Z,

I just double-checked and it doesn’t look like bookmarks are available via the Roon API. Sorry!

//TB

@Gareth_Irwin ,

If it’s dropping the connection, then it’s likely some network related issue between Roon and your computer unfortunately (though I guess it could be some power saving option, too). However, you shouldn’t have to go the configuration to click Connect, though. Using any of the buttons (when they’re greyed out/connection is lost) should attempt to reconnect. So theoretically the worst case should be that you have to hit “Play” for example twice.

//TB

thx for checking @Tomi_Blinnikka !

Z