Roon plug-in for Elgato Stream Deck released

OK let me put it another way. How do I install this on the basis my roon server is in a docker?

Cheers

You only need to install the Streamdeck plug-in using the normal instructions: https://bliny.net/streamdeck-roon/. You don’t need to install anything on Roon.

It will attempt to communicate directly from the client machine with the Streamdeck to the Roon Core on the specified host and port (9100 by default).

Why does it talk about roon extensions then, and furthermore did not work for me? I installed the streamdeck extension and it asked me for the roon core, I entered the ip and nothing, but the instructions you link to says ‘step 3, enable roon extension’

Feeling a bit thick this evening, sorry.

Roon requires that anything that connects to it needs to be enabled for security. The steps are in the doc as follows:

Step 3: Enable Roon extension

  • Open Roon.
  • Open the main menu, and select Settings .
  • In the Settings window, select Extensions and find the the Elgato Stream Deck controller extension.
  • Click Enable .

You don’t need to install anything in Roon, just enable the what Roon calls an “extension”, i.e. the Streamdeck plug-in.

OK thanks. Its not working for me.

I install the roon bit in streamdeck. I add a button it asks me to enter the host name for roon which I do, and I tried IP address the ‘connect’ button remains greyed out. There is a little ‘tick’ by the IP address.

The problem is I cannot click connect

In roon settings extensions, there is no streamdeck or anything, I really fail to see why there would be one there, surely I have to install something lol?

Ok not going to lie it was an error between the keyboard and the chair. The port 9100 was already typed in but I had to type over it for it to register.

I’ll go back to my hole.

Glad you got it connected!

Great news!
Many thanks @Tomi_Blinnikka

I’ve installed and it works smoothly.
The only issue I have is regarding volume button that are dimmed. I’m using Harmony external volume control maybe it is the issue ? Any idea ?

Hi zeb,

That sounds you also have DSP volume control disabled in Roon which would prevent the Volume buttons from working. I can’t for example control the volume on my Oppo HA-2 which has a physical knob unless I enable DSP volume control in Roon.

Could that be the case?

//TB

Yes exactly it is up / down volume for my external amp controlled by Harmony plugin.
Too bad that Roon API does not expose it :frowning:

I will try to hook my amp network API to button instead.
Thanks for your feedback.

@Tomi_Blinnikka I’ve seen you released 1.0.7 but my streamdeck is stuck at 1.0.5.
Is there a specific things to do to update ?

I’ve submitted it, but it hasn’t been published yet. Since the whole “app store” is manual, I think the delay is due to August summer vacations in Germany.

If you need/want it sooner, I can email the new version if you DM me your email address.

//TB

1.0.7. should now be available via the the Streamdeck app.

//TB