Roon poor detection of DAC connected to iPad

Core Machine (Operating system/System info/Roon build number)

SonicTransporter running Roon v1:7 Build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core connected to gigabit ethernet. All wifi routers use gigabit ethernet backhauls. Wifi is Wifi5 Apple Airport Extremes.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

The zone in question is an iPad Pro connected to the network via wifi. I have my headphone dac/amp (Fiio Q5s) connected using it’s standard micro-usb to usb-A cable and I have Apple’s usb-A to usb-C adapter connected to the iPad Pro.

Description Of Issue

Although the native Qobuz app can always play to the Q5s without any problems, when I use Roon instead it almost never sees the Q5s and in fact the iPad disappears as a zone option.

The only way I can get it to work is to launch the Qobuz app and start playing then switch back to Roon and start playing. It does not always work right away but after trying it a few times it does work.

Is there any way to improve Roon’s detection of dacs plugged into the iPad?

Hmm, don’t know why Qobuz app can detect the DAC and Roon can’t, but if your DAC is bus powered then it might not be getting enough juice for Roon to reliably see it.

For awhile, I had to use the DAC in my iPad to drive my headphones and Roon always found the zone.


Thanks for your response. The Q5s is battery powered and I always disable charging via the iPad, so there is no power draw.

Yes, the Qobuz app sees it fine but Roon does not.

I should add that the iPad is on the most recent production OS version (not beta).

Just to clarify, the iPad appears as an output zone until you plug in the DAC, and them it disappears?

That’s correct.

Hello @Adeeb, I’ve enabled diagnostics for your iPad. Could you please open Roon on said iPad so I can collect the report? Thanks!

Thanks @nuwriy – Roon is open on the iPad and I have tried to plug in the Q5s.

Today’s results:

  1. Pressing play the first time shows:

“Failed to initialize the audio device”

  1. Pressing play another time crashes the Roon app on the iPad.

Today I was also not able to play through the Qobuz app when the Q5s is connected, so I am restarting the iPad.

After restarting the iPad:

  1. I started playing through Roon without the Q5s plugged in then plugged in the Q5s and it worked!

  2. I then unplugged the Q5s and played directly through the iPad again which also worked.

  3. But When I plugged the Q5s in again (i.e. the 2nd time) I saw the same “Failed to initialize the audio device” message and crash behavior as indicated above.

Hi @nuwriy,

While the issues described above (including the crashes) still happen in the usage I described, I have found that if I keep pressing the back/previous button on the DAC as I connect the USB cable to the iPad, it tends to work. In cases where it still does not work even with this technique, force quitting Roon and trying again usually works.

Note: this technique was found as an obscure suggestion from Fiio.

Hello @Adeeb, and thanks for the update! Our team is still investigating this issue and is working on getting a Q5 for internal testing. I’ve updated your ticket with this post so the team can keep this info in mind.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.