Roon Poor Quality Sound on Sonos Devices

Hi Roon community and @support, I have to say that I´m some kind frustrated with my Roon experience. After a two week trial period with plenty of technical issues that took me to buy a Mac Mini for simply running the Roon software (nothing else is running there) among others things, I still decided to support the Roon team for their excellent support and of course I liked the software very much specially for all the NEW music content that one can discover, but one of the most annoying things that I have been encounter lately is POOR sound quality, and when I say poor quality is simply that…too low, lack of fullness, loudness and you have to increase the volume a lot in order to have a still far away sound experience when compared to simply listening trough the Sonos App directly that was my “music player” until I came to know Roon…one have to increase the too much the volume to find a still far away sound quality/experience…I also have to say that Im not by no means an audiophile , BUT I LOVE music and I can say when something is sounding great or not. Im not sure what Im doing wrong but me setup is very simple…I use Roon to stream music to Multiple Sonos devices around my house.

Follows my setup:

Roon running on a Mac Mini Late 2014 Core I5, 4GB Ram
Last version of Roon @1.5 (64bit)
Multiples IOs devices, all of them with latest SO
Mesh wifi TP-Link Deco with multiples end points (routers) with solid speed through all the house
40GB of own FLAC music on mac mini and Tidal premium account but not hifi.

Please your help and guidance since at this point Im really frustrated.

Thanks in advance.

Hello @Enrique_Donoso,

Thanks for contacting support and I do apologize that you seem to be running into these kinds of technical issues. Can I kindly ask for you to provide a screenshot of your Signal Path information when streaming to your Sonos Zones? The signal path allows us to identify what kind of quality is expected to be received by the endpoints in a setup and will give us more information to work with here.

You should also know that we have a fully-fledged DSP engine built into Roon which you can use to fine-tune your preferred audio settings if you prefer louder volume in general.

Please let me know the above information when possible.

Thanks,
Noris

Thanks noris. Here you have the screenshot of one song to only one device (zone).

I’m relation to the DSP engine, I’m really not into that technical moves…just want to enjoy my music.roonsignal2Roonsignal1

Enrique,

From your screen shot you seem to have volume leveling switched on.

It is possible that your LUFS setting is the roon default of -23 LUFS. This may not suit your equipment or listening tastes. Try this:

Right click device -> Zone Settings -> Target Volume Level

Experiment with lower LUFS. Some roonies prefer -18, others max out at -14.

Thanks Tony. I double checked and the volume setting is in AUTO and the LUF target is -14. Follows a print screen. I also tried with higher LUF and in deed is worst…very low level of sound…I don’t know what is the best word to use but is kind of empty, no life in the sound…like turned off.

roonLUF

You are not relating to sound quality but to sound quantity. There is a difference. Just turn up the volume or turn off volume leveling.

AJ

Hello @Enrique_Donoso,

Thank you for providing that screenshot. As others have said this is due to volume leveling. I would turn that option off in the Zone Settings screen as the SONOS seems to be negatively impacted due to this. Please let me know your findings after doing so.

Thanks,
Noris

Thanks to all for your replies.

@noris, I already turned off the level setting option and improved a lot…little to no difference with the Sonos App. Thanks a lot.

Is there any other recommendation and maybe a Roon DSP manual or instructions to follow si to see if I can improve little more all this.

Also I will be including a Naim Uniti streaming device to my setup, so maybe more knowledge how this all works could help.

Many thanks.

Have you checked your files to see if they all have replaygain tags? If you have there are a few things you can try that might help especially if you are reluctant to switch off volume levelling altogether.

There is a global import setting for replaygain tags you can experiment with. I haven’t had your experience of everything sounding bad but I have rips from years ago I can no longer remember how I ripped, with what, or what settings, especially replaygain I used. With problem files, with the same symptoms you describe, switching on these replaygain settings has worked for me.

I also on occasion reconvert with foobar (same codec, bit rate etc.) but set the replaygain option to write out replaygain during conversion. You don’t want to do that globally as it is irreversible, but it has fixed problem live and bootleg files I have which were not high rez anyway so the reversibility of the conversion was unimportant to me.

I find volume leveling does the same kills the musicality on my systems not Sonos but Naim and Allo. I decided to turn it off and just adjust volume as needed.

Hello @Enrique_Donoso,

Glad to hear that it is sounding better with volume leveling turned off. To find out more about our DSP engine, please take a read over the following link: https://kb.roonlabs.com/DSP_Engine

I recommend the parametric EQ if you would like the sound to have different EQ settings (such as bass-boosted, lower mid levels, higher treble, ect.) You can read more about our Parametric EQ here: https://kb.roonlabs.com/DSP_Engine:_Parametric_Equalizer

Thanks,
Noris