Roon program corrupted. Reinstalled program but still corrupted

I am struggling to get Roon connected to my music server.

I use a 2018 MacBook Pro connected wirelessly to my Wadax Atlantis Server. Everything worked fine until I upgraded the MacBook Pro to Sonoma 14.1.2, now upgraded to 14.2.1.

The Roon icon is on my desktop, but when I open it, it displays “waiting for your Roon Server.
The server is visible when I open Network.
When I open Roon, the top line displays: “ Roon, edit, view, window, help”
When I click on the word “Roon”, the drop down menu begins : “About Roon and Settings”,. BUT when I click on either of those drop-downs, nothing happens!!!

Assuming that the Roon file was corrupted by the Apple upgrade, I deleted Roon and reinstalled from the website, but it operates the same as the prior version on my MAC. Nothing happens when I click on “About Roon” or

I would appreciate any help you can give me.

Before deleting and reinstalling Roon, I did a screen share with Apple support who reviewed my computer and said it was working properly.

It would definitely help if you posted in the format required for this section of the forum. As an example, it’s not clear if your Mac is just a control point/remote or if it is also your Roon server.

@Merek_Rubin, per @DDPS’ suggestion, it is not clear where to start. Can you please complete this form below and update it with the information requested?

Roon Server Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

The Wadax Atlantis Server is the core.The Wadax Atlantis Server contains the latest updates per Wadax.

The 2018 MacBook Pro is the control point.

Apple support did a screen share with my MacBook today and said it was functioning properly.
See my responses to the following question below.

See my additional responses above.

I think there is only one version of the Wadax Atlantis Server, which is updated periodically by Wadax.

The 2018 MacBook Pro has a 2.7GHz Quad- Core Intel Core i7 and memory-
16GB 2133MHz. The Mac OS software is Sonoma 14.2.1

My setup is WIFI. An Apple Extreme is connected wirelessly to my network. The Apple Extreme is connected by Ethernet Cable to the Atlantis Server and the Extreme is connected wirelessly to the MAcBook.

The Atlantis Server is connected by USB to my Atlantis DAC,
There are about 700 music albums on the Atlantis Server on a 4TB drive in a bay inside the Server.

When I open Roon on the MacBook, next to the Apple Logo on the top left is “Roon”.
When I click on Roon, I get a dropdown box, the first 3 items are “About Roon”, “Settings” and “Services”. When I click open “About Roon” or “Settings” the entire dropdown box disappears.
When I click on "Services; and then “Services Settings” I get the main computer "System Settings"page opened to “keyboard”. Superimposed over this page is a page titled “Launchpad and Dock”.

Since I cannot access “Settings” in the Roon dropdown I have no way to change any settings.

When I deleted and reinstalled Room on the MacBook I still cannot access "

You can also use the Finder’s “Go” menu with the option key held down to get to your Library folder and remove those files/folders manually if you wish.

@Merek_Rubin , the support team is a bit short-staffed this week so I’m hoping that this points you in the right direction. I suspect you may be having a firewall configuration issue on your mac and that is preventing communications between the Roon remote there and your Wadax server.

Try this:

  1. Open the macOS system Settings window
  2. Select “Network” in the left column
  3. Select “Firewall” in the right column
  4. If the firewall is enabled (the switch is green) then switch it off
  5. Quit Roon if it is open and start it back up

If the above steps resolve your issue then you will want to configure the firewall to allow Roon to talk while still protecting your computer.

  1. Return to the firewall configuration screen
  2. Enable the firewall (flip the switch so that it is green)
  3. Click on “Options”
  4. Look for items in the list with “Roon” or “raat” in them and make sure that they are set to “Allow Incoming Connections” (see the image below for an example and note the “com.roon.XXXXX” items. You may have more or fewer Roon or raat items than you see here and the important thing is to ensure that they are all granted access.
  5. Click OK
  6. Quit Roon if it is open and start it back up

This should result in Roon being able to connect to your server while still allowing the firewall to protect your computer.

If you’re still stuck after this then please reply back here and @connor can help you out.


Roon corrupted by Apple upgrade. Problem solved by switching to a different Roon Core on my MacBook.

To all of you who responded to help me, thank you. I very much appreciated your willingness to help and your detailed comments.

The Roon Community is something special!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.