Roon Radio always stops after a few tracks

Roon Core Machine

Roon Core 2.0 is running on a Synology with DSM6, my endpoints (Macs, iPad) have Roon 2.0 installed everywhere, all up to date.

Networking Gear & Setup Details

Router: FRITZ!Box, Synology is hard wired and has a fixed IP on the local network

Number of Tracks in Library

70,000+ tracks

Description of Issue

After the sometimes difficult installation hurdles, I start spending the rest of my testing time doing nice things: Listening to music.
First of all: I only listen to local music (that’s why I have problems with the new “allways online feature”), but I linked to my account at Qobuz so that Roon can give me notifications about new releases. For Roon Radio, I have set it to only play tracks from my large local library.

So I choose a piece of music and activate the radio function. After two or three tracks, the radio stops by itself – which is not how I planned it. Radio always stops at the end of a track, never in the middle.
When the radio is playing and I want to see details of the track or artist that is playing – the radio stops. Not always, but often.
Often the connection to the core is lost. When reconnected, the radio doesn’t pick up where it left off (I would expect), but plays the next track in the playlist.

In these attempts, my iPhone is at a fixed position in the good and stable (!) WLAN as the Roon endpoint, and I listen to the music via Bluetooth DAC (ifi Go Blu) on
headphones. I’ve tried it many times – the Roon Radio seems to be broken on my end, and I have no clue what that might be.

I’d like to switch back to version 1.8 probably (because of the internet-online constraint, and since ARC doesn’t work for me anyway), but since that involves rebuilding the database, I shy away from that effort, and prefer to listen to some music – but that’s another topic.

Still, does anyone have any ideas on how to make Roon Radio play longer?
I have rebooted the server and the Roon remote devices tentatively, with no change.

So even after a year there is no reply :face_with_raised_eyebrow:

Oh, two years in total — and I am already going nervous after no reply after 2 days.

[Roon Radio always stops after a few tracks]

So we have to wait patiently… 8 days till the end of my free trial.

Are there any new findings on this topic?

Hi @Holger,

You’ve endured an unforgivable wait time for a response - please accept our apologies.

The most recent Core diagnostics show remote connectivity failures to two endpoints (a Google Cast device and an Argon Audio device) and an iOS remote. These failures affect both RAAT and Roon (both the audio stream and control). The timing of these failures indicates they likely might have interrupted Roon Radio sessions, but it’s also fully possible they’re unrelated and Roon is recovering. Any clarification on connectivity and performance outside of Roon Radio you can provide will be helpful as context.

Are you using a VPN on this network?

Two steps we can take in the meantime if you haven’t already at this point:

  1. Try changing your DNS server in your router settings to Cloudflare DNS, Quad9 or Google DNS, although I’d recommend Quad9 currently.
  2. Refresh RAATServer, if you’re willing to create a backup and restore it (otherwise, you’ll lose DSP configurations and other Zone settings by taking this step).
  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Two other notes, although unrelated:

  • NATPMP is logging unrecognized address failures for a NATPMP-enabled device on your network. I recommend disabling IPv6 prioritization on any networked device you’re using with Roon in the meantime.
  • UPnP is similarly reading precondition failures. Verify UPnP is up to date by checking your Fritz!Box firmware, if you haven’t already, and similarly updating firmware on any UPnP-enabled endpoints in your network.

The team will be watching this thread for as prompt a response as possible. Thank you again for your patience.

Hello @Connor ,

thank you for taking care of my problem.
Unfortunately, I’m on the road for the last few days and I can’t change any settings on the router or the server.

My router circumstances are not ideal: we have a fiber modem switched in bridge mode. Attached to it is a FRITZ!Box as the actual router (I think it’s called double NAT then – but I’m not a network expert). This is probably the reason why the FRITZ!Box is not directly reachable from the internet and portforwarding for Roon ARC does not work. *)

I have therefore installed Tailscale on both the Synology (Roon Core) and my iPhone and can successfully listen to Roon Radio, with no problems.
I hope this works when I get back home, on my local system. The only thing I changed in the Roon settings: I disabled my Qobuz account in Roon – but I don’t know if there is a connection.
I’ll try Roon Radio locally in a few days when I get back home.

I usually work from home with a VPN as well. Does this affect the functionality of Roon?

*) I bought a new FRTZ!Box (FRITZ!Box 5590 Fiber) which connects directly to the fiber, this should simplify the accessibility. However, we have our internet service provider to install a passive optical telecommunications outlet first, which can take some weeks…