Roon Radio - Can't play AAC streams - Playback was interupted because a track failed to load

Roon Core Machine

  • Roon Core 1.8 (build 903)
  • Ubuntu Server 20.04.4 LTS x86_64
  • Intel i7 9700 cpu
  • Gigabyte Z390 UD Motherboard
  • 16gb Ram Corsair Vengeance LPX Black (2x8GB) 3200

Networking Gear & Setup Details

All wired ethernet. Netgear switches.

Connected Audio Devices

Ropiee endpoints onto various DACs

Number of Tracks in Library


Description of Issue

I am having a problem with Roon Radio where it will not play AAC streams. I primarily use the BBC channels, 1,2,3,4,5 etc and have not had this issue previously.

I installed Roon Server following these instructions. I loaded ffmpeg at the time, but I wondered if I had missed it. I tried to reload and said I had the latest version.

If I choose an mp3 stream it will play no problem. If I try a AAC stream I get the following issues - Playback was interupted because a track failed to load

Any suggestions on how to fix?

To be clear, if you play a BBC radio station’s MP3 feed, it works, but not the AAC? Have you tried all AAC streams, or just the 320kbps one?

Furthermore, did you add them manually or add them from the Live Radio page? Finally, are you in the UK or elsewhere?

P.S. Reboot your server, too.

Thank you for responding.

So, I am in the UK. I have rebooted the server.

In terms of BBC stations, MP3 works. AAC 320kbps does not work. AAC 128 kbps does not work. However I just tried 96 kbps and this does work. Now I am even more confused.

I just tried a number of other stations and most don’t have higher kbps although I could play P4 Dalarna from Sweden at AAC 128 kbps.

None of these were added manually.

I don’t believe this is a codec issue. Normally, those bit rates are only available for offshore users. Are you using a VPN on the Core machine?

No, no VPN on the server. I am sure they use to play, but maybe I was mistaken.

As you’re in the UK, they should play. Why they don’t is a mystery, but not to do with codecs, since you can play MP3 and AAC.

Do you stream anything from TIDAL or Qobuz? If not, what Internet connection do you have?

Yes, I have a Qobuz sub. I have a 80 meg line, so not that fast but I can stream 4k video etc.

80Mbps is more than adequate. Does Qobuz steam through Roon as expected, i.e., are the only issues with Internet Radio?

No issues with Qobuz streaming, I can stream 192khz no problem, so it is a little odd.

Same problem for me, in UK, no AAC radio station working (including 96k on BBC)? QNAP nas for Roon core.

No problem here, as mentioned earlier. Are you and @tahsu on Virgin or an Openreach broadband provider, e.g., BT, Sky, Plusnet etc?

I’m on Sky broadband yes

Oh well, that theory doesn’t hold… I’m on Sky too! How about your DNS servers?

Sorry Martin - DNS not my strong suit, do you mean what DNS server is my Sky modem connecting to? If so, this is what I get from the Sky modem admin page: IPv4 Domain Name Server:,

So just to be sure, you can play MP3 stations like the OP can?

Yes, that’s it. I use and although I doubt this will be the cause.

Yes listening to radio right now on MP3 - seems the stations that have both, I can hear the MP3 fine, but the AAC’s don’t work at any bit rate for me

The OP can also play AAC, but not the highest bit-rate.

Can you try the 96kHz AAC?

BBC R2, tried 96kbps AAC but nothing, doesn’t connect, MP3 128kbps works fine however