Roon Radio Doesn´t start

Hi there

I am experiencing some troubles using room radio. Actually the service never had worked. Appears only Nothing Similar to Play (even with the Beatles!!) please see the attached.

I am running a Core in a MacBook mini. Connected Vía Wi fi (I can not connect it via ethernet). I checked the firewall and nothing happens

Even When I put Discover (looking for something new) only offer me MY LIBRARY!! is so annoying :(.!
I read mostly of topics and the only solution achieved was when support team made a diagnosis

Please help

Kind regards

Actually is not only the radio. If I look for any tag artist only look for artist in my library. Thus never offers me something new :(. What’s wrong?

What streaming service(s) do you use?

Also, Discover is designed to work with only your library: “Discover automatically curates your music library to help you find hidden gems …” This includes bother local and streaming media in your collection.

Hi Martin

I using Tidal in a Mac mini (uses as Core). Also I use a MacBook Pro joined to the core. But radio doesn’t work either in both setups.
I turned off the firewall without improvements.

Are you seeing Recommended for You when you’re on an album page. Also, try restarting the Core.

Dear Martin

I’ve tried everything, even I uninstalled room and then installed again.
On the other hand, when I am in an album page did no appears “recommended for you” only “similar to” and Inspired by. I restarted the Core and the computer also but it didn’t work

I think you may need to connect your core using Ethernet. Try this and see if that helps.


I have the same Issue. I put tidal at any disc (the Beatles for examples) and appears nothing similar to play.
I heard only good things about Roon but I need the radio.

Please help

Hi @Sebastian_Meier,

Welcome to the forum.

Does this behavior occur for your Core’s System Output zone as well? What kind of setup do you have? Can you provide more information regarding your Core and Networking Gear (including manufacturer/model)?

Is there any change in behavior if you try to reboot the Core? Does starting Roon Radio off of another artist (such as Miles Davis) work as expected?

Hi Sebastian,

It looks like you had multiple threads open, so I have merged them into one.

My previous questions have been answered in this thread, so I have gone ahead and activated diagnostics mode for your account and what this action does is automatically upload a log set to our servers for analysis.

I can confirm that the report has been recieved and I have passed it on to QA for further analysis. I appreciate your patience until I hear back from QA!

Hi Noris

Thanks for the diagnosis mode. I read that for other user it’s works. Now I have to wait? it gonna fix itself?
I tried to connect using ethernet Aldo but did no work either. I am not sure about the zones, but I attaching a couples of pictures.

Thanks for helping me, kind regards

Hi martin I’ve tried but did not work, Noris said to me that gonna run a diagnosis. So I gonna wait for it I suposse.

Kind regards

1 Like

Hi @Sebastian_Meier1,

Diagnostics mode uploads a log set to our servers. This report has been passed on to QA and they are performing the analysis of the logs. Once analysis is complete, I will reach out to you once more with further troubleshooting steps, thanks!


for external streaming issues often it can be a DNS setting issue. If can ensure one of your DNS entries or public addresses this might help

Hi Wizardofoz.

I changed the DNS and I put did not work. Then I put neither. Finally I put both and did not work :(.

Thanks for the advice anyway

Are you using any VPN software … noticed you are in Chile…perhaps not the best networking infrastructure there?

Hi again
I have to looking for what mean a VPN, and not I have any software using that protocol.
Hey don’t be bad about Chile we have very good internet here LOL. But seriously the internet infrastructure is good.

Perhaps not with respect to streaming connectivity to the likes of tidal maybe.

I am not sure about the connectivity with tidal. But Audirvana and Tidal works perfectly (although Audirvana doesn’t have radio). Thanks for the help :slight_smile:

Hi Again

DO you have any new about diagnosis? I already tried today at 702 AM UTC/GMT -3. But still not working

Kind regards