Roon Radio - Nothing similar to play

Core Machine (Operating system/System info/Roon build number)

Core: I tried it on QNAP TS251B and MacBook Pro Mid 2014
Roon Version ist 1.7 (build 528) stable
Roon Client is running on Android Device and on Mac and on iPhone 11 Pro

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi, AVM Fritz!Box 7590

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chromecast, MacBook, Samsung S9+, iPhone 11 Pro

Description Of Issue

No matter which Artist I select I always get the message “Roon Radio: Nothing Similar to Play” after starting Roon Radio. So I cannot use this feature. I tried to restart the core and the clients but nothing helped.
I use Roon together with Tidal.
Please help


I’m having a similar issue. Roon radio defaults to my library. Won’t play/find anything similar from Tidal or Quboz.

Hi @RobertK,

Just to confirm, are both of the Core machines you are using connected via WiFi? Is there any change if you use an Ethernet connection?


yes both are connected via WiFi.
Can’t connect them using Ethernet.


Hi @RobertK,

Generally, as noted in our Networking Guide, we recommend using an Ethernet connection whenever possible. It’s hard to say just yet if that’s the reason for what you’re seeing, but it’s definitely possible.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi @dylan ,

Diagnostics sounds good.
I just tried it and got the same message.
Time: 18:56 Berlin Time


Thanks, @RobertK.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi @dylan,

I don’t know what you did, but today it was working without a Problem. It was the very first time I could use the radio function.

Thank you

Hi @RobertK,

I’m glad things are working for you now! If you see any issues return please do let us know.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.