Roon Radio skipping song halfway through

Core Machine (Operating system/System info/Roon build number)

Mac Mini 2018 / OSX 10.14.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lynx Hilo, Bluesound Pulse 2

Description Of Issue

Every now and then when I use the roon radio function, with Tidal, a song will stop before the end and the next one will play. My internet isn’t exactly great but I didn’t have this problem before the last update… Any clue why this can happen?

Hello @Mathieu_Dulong,

The next time that this occurs, please send us a set of Roon logs and we’ll have the QA team take a look at what’s going on.

Use the “Option 2” instructions from this guide


Ok I will thank you.

So, the problem just happened, here’s the Roon logs.

Hi @Mathieu_Dulong,

Thank you for sending the logs over. In the logs, I noticed that you are playing to both the Pulse and the Hilo zone in a group. If you ungroup them and try to play to them separately, do you notice the behavior occur just one one of these devices individually?

What is your download/upload speed? Can you please go to and let us know the test results?

I will try to play music on one of the system only to see if that helps.

My internet is 10mbs but the thing is before the Roon 1.7 update I never had this issue, not even once and now it happens quite a lot. That’s very annoying.

Hi @Mathieu_Dulong,

Yes, please do try streaming to individual zones as a test.

10 mbps is quite on the low side, and we can’t make guarantees that it would be enough for high-resolution streaming.

If you have the option from your ISP to increase this, I would suggest to do so. Two other things which may also help -

  1. I would try changing your router’s DNS servers from the ISP ones to Cloudflare/Quad9. This should increase the speed at which DNS queries are made and help a bit.

  2. You could try setting a lower limit to the max sample rate when streaming in `Roon Settings -> Services -> Edit button next to TIDAL/Qobuz -> Streaming Quality.

I will try that for the DNS but as I said it used to work perfect in 1.6 with everything else the same.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.