Roon Remote App cannot connect properly to the audio output device on my MacBook Air M1

Roon Core Machine

Roon on NAS on my Synology
It works fine with all my devices - except the MacBook

Networking Gear & Setup Details

Irrelevant - the network works fine

Connected Audio Devices

iPhones - works fine
iPads - works fine
Raspberry PI with SPDIF Hat from Allo DigiOne - works fine
Windows 10 PC - works fine
MacBook Air M1 - the Problem device

Number of Tracks in Library

below 10000

Description of Issue

I have bought a new MacBook Air and tried to use it also as an Roon Endpoint (Airplay) while browsing the internet and listening with headphones

This kind of usage works fine with my iOS devices (iPhone and iPad)

The Remote App on my MacBook cannot connect properly to the audio output device on my laptop
It works fine if I choose the raspberry Pi with the Allo DigiOne Hat as the output device

The App detects the Output device from my MacBook but I can’t play through it
It gives me an error message: unexpected error communicating with the audio device - too many failures stopping playback

It appears to be a local problem on my MacBook

MacOS Ventura 13.1 is the OS Version running on it

Hi Georg,

Roon Support is off for the holidays, but, we might be able to help. If you posted a pic of your Settings/Audio page we might notice something.

I don’t think that the images will be very helpful, but here you go:




Many thanks in advance for the support

Kind Regards
Georg

I would try rebooting both the NAS and the Macbook as a first step.

Hi @Georg_Hutter,

Are you still experiencing problems with your MacBook Roon Remote connection? A quick glance at recent diagnostics from your account shows several network failures in RAATServer and Roon logs, so the tech support team is suspicious that you’re still encountering problems with Roon on your local network.

As an initial step and to refresh conditions, please create a new instance of RAATServer by taking the following steps. Be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

We’ll keep an eye out for your response. Thank you!