Roon Remote can not connect to Roon Core (iOS)

Core Machine

MacOS 11.4, 3.1Ghz Quad Core Intel i5, 8GB DDR3

Network Details

Roon Core connected to cable modem via ethernet, and working properly. Trying to access it via Roon Remote on wireless, my firewall is switched off on Mac and cable modem.

Audio Devices

I’m currently using Airplay, Chromecast and Arcam ST60.

Library Size

1234 Albums, 12,106 tracks

Description of Issue

My Roon Core is set up on my Mac, and playing fine there. I can also use airplay in my other devices. However, I can not connect Roon Remote to my Core, even though I tried everything. Roon Core is already enabled to accept connections from remote. When I turn that setting Off and then back on, for about 30 seconds I get the below message (see attached pic). Basically, I can not connect to Roon Remote from either my iPhone or iPad even though they are connected to the same network.

Can you help me sort this out, thanks - Tunc

Hello @Tunc_Yildirim,

Thanks a lot for letting us know of the issue you ran into and sorry about the trouble :sweat:

Could you please confirm that all devices you use with Roon have the latest version installed? Also, do you have any firewall or antivirus? If so, could you please temporarily disable it? Do the remotes connect then?

Hi - I installed the remote on my iPhone and iPad, both have the latest version (1.8). The Roon Core is on my iMac and I’ve disabled firewall both on my network and my mac. I’m not using any anti-virus software on the mac.

I wonder why the Remote sees the Core intermittenly (see the picture in my earlier post) and fails to connect to it.


Thanks for the quick reply. One more question, if I may, could you please check that all devices are on the same IP?

For example, of the Core’s IP address is, the remotes address needs to match except for the last section. So 192.168.1.X

That’s correct. Mac (Roon core) IP is, iPhone (remote) IP is, iMac (remote) IP is All have same subnet mask (

Thanks for checking on that, @Tunc_Yildirim. I appreciate you sharing all the info - I’ve connected with our technical team and you should hear back from one of our technicians on this thread.

Please, bear with us for a little bit :nerd_face:

Have you allowed the roon app access to the Local Network in the iOS privacy settings?

Yes local network is enabled

have you removed and reinstalled the app? is it the same issue on both iPad and iPhone? what about from another Mac? or PC?

Hi Rebeka, any update from your technical team pls?

This is essentially the same problem I am having. See my post this evening. I just don’t get it because nothing changed and then one day it stopped working.

I have completely the same problem.
Roon Core 1.8(build 795) is running on iMac Big Sur ver.11.4
Roon Remote latest version 1.8.00795 on iPhone iOS ver.14.6

Firewall on iMac is disabled.
Both iMac and iPhone connect the same network.

Maybe the root cause is in the software itself?

I use Roon Remote on 4 devices (a desktop PC, a laptop, an Ipad Pro and an Iphone). Everything worked normally yesterday. This morning, the Ipad displayed the same error and failure to connect. The Laptop still worked normally. I did a full shutdown on the Ipad and brought it back up. Issue resolved. Seems something buggy in the iOS version.

I solved the problem.

In technically, I did followings.

  1. Remove Roon Remote on iPhone and reboot iPhone.
  2. Install Roon Remote.
  3. Quit Roon Core on iMac and then launch Roon Core again.

I guess that restart Roon Core was the key.