Roon remote cannot find CORE after CORE PC moved to new SSID

Roon Core Machine

Windows 11 Pro on Beelink Ryzen 7 4700 with 16GB RAM

Networking Gear & Setup Details

Synology RT2600ac (don’t know what YPN is)

Connected Audio Devices

Using USB DAC Schidt Modi 2

Number of Tracks in Library

2400 tracks

Description of Issue

When I first installed CORE it was connected via Wi-Fi to an extension of my primary network through a TP-link wi-fi extender. Roon remote connected to my primary SSID from my Synology router had no trouble finding and using the CORE
I moved the CORE PC to my living room with a good wifi connection to my Primary SSID from the Synology router (instead of vonnecting it to the -EXT SSID.
Roon remote can no longer locate Roon CORE.
It works if I change the CORE PC to use the -EXT SSID burt that has a much weaker signal.

Alex, welcome to the community, let’s see what we can do to help. Can you provide any more information about your network? It seems you may have a weak signal which could impact the quality and reliability of the Roon connections, or have two networks in place, and Roon requires all devices (Core, Remotes, and endpoints) to be on the same network (subnet technically).

You have a Synology router, but how are TP-Link WiFi extenders connected to the Synology router and to each other?

wifi is not recommended for connecting a core machine to your network

The Tp-link wifi extender connects to the Synology router via WiFi and extends wifi coverage to my office in a separate building. I first installed CORE on the dedicated PC while working in my office. At that location the wifi signal from the extender is stronger than from the Synology router. The CORE connected to the wifi from the extender on ssidxxx-EXT.

I was able to use Roon remote on both ssidxxx (from Synology router) and from ssidxxx-EXT (from the extender).

Then I moved the CORE PC from my office to my living room. In this location the wifi signal from the router is much better than from the extender.

But now, if the CORE PC connects to wifi from the router (ssidxxx), roon remote can no longer locate the CORE.

You need to make sure your SSID’s are both getting IP addresses in the same range as the router…everything on one address range. could be a firewall issue too or network type setting windows. that usually trips people up too.

1 Like

It sounds like you have two networks running with, as @wizardofoz notes, two IP address ranges. Roon needs the same address range (the same subnet) for it to work across all devices. Can you convert the TP-Link extenders to bridge mode so they are being served the same IP address range as the Synology?

I only have a single network running. Both SSIDs are getting addresses in the same range. When I first installed the Roon CORE on the PC, it was connecting to my wifi network via the extender and I was using Roon Remote to access it with no problem from my phone and from a tablet. Both the phone and tablet connected to wifi from the SSID on the router and the CORE PC connected to wifi from the extender.

Since moving the CORE PC into my living room closer to the router and connecting it (and the Roon Remote devices) all to wifi from the router’s SSID, the Remotes can no longer locate the CORE.

I have completely uninstalled and re-installed the Roon CORE and Roon Remotes and still cannot access the CORE from any remote.

As another test, I installed RoonServer on my MX Linux laptop and the Roon Remotes work perfectly.
I just can’t get my Windows 11 CORE to function. Even directly on the Windows PC, if I click to locate the Roon core it is unable to find it.

Hello Robert. Please see my reply to wizardofoz above.

Turn of the windows fire walls and make sure the network settings are not restricted for sharing etc like public network setup

1 Like

I would suggest:

… turn off the Windows firewalls temporarily as a test. If things start working then it’s your firewall settings that need adjustment to allow Roon traffic on your home network.


Thanks everyone for your suggestions. Ultimately I found the problem. It appears that when I first brought the PC running CORE into my living room and connected it to my primary wifi SSID, Windows 11 set my wifi connection to “Public”. The rules in the firewall do not allow incoming connections when the wifi connection is “Public”.
I changed the wifi setting for my connection to “Private” and now everything is working well again!

So nice to have Roon working in my home!

Excellent Alex, glad you are up and running again. I marked this as Solved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.