Roon Remote Crashing on PC

Core Machine (Operating system/System info/Roon build number)

Nucleus+:
OS Version 2.0 (build 1223)
(the following info is old and I cannot update because I cannot see the Nucleus+ on my network) stable / Roon Server SW version 1.6 (build 416) stable (64bit) / Roon Labs SW version 1.0 (build 9) stable. System status = all OK.

Networking:
DHCP IP 192.168.1.240 (successfully responds to network Ping command). Netmask/Gateway/DNS are all correct settings.

Connection is Cat5.

Power and networking activity lights are active.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ISP is Cox Communications. Cable modem is Cox Communication provided ARRIS model TM3402A. Router is TPLink Archer AX11000 Dual band 802.11 AC Gigabit. Switch is Netgear model FS105 (10/100Mbps).

Network host is home built Windows 10 pro OS with Intel coreI5 processor, 16 gigs memory and lots of room on HD. Private network discovery and file share are on and share password requirement is turned off. Host name is “TSDSKTP1” and shared folder is “roon.” Security is setup for “everyone” in the private network to have full access to shared folder.

Roon remote is installed and but not functioning on Vizio tablet that came with TV, Samsung Galaxy TabS tablet and Samsung Galaxy S22+ mobile.

I run the PC host with Cat5 connection.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio Direct Stream DAC is connected via Cat5 through the same Netgear switch that Nucleus+ uses. PS Network bridge card appears in host network screen. Nucleus+ does not.

Description Of Issue

Roon Remote fails on all devices. S22+ was working, but PC was crashing. I uninstalled remote on PC and downloaded latest version for PC. Now all are frozen. Roon ARC still works. Rebooting all equipment had no effect.

I am confused, does the Nucleus+ identify the Roon Server version as build 1223 (which would be current) or Roon Server SW version 1.6 (build 416), which would be very outdated?

Current remotes crash right away if the Roon Server version is outdated. If yours is 1.6 (build 416) this would explain the remote crashes.

Can you go in a web browser to http://nucleusplus, http://nucleusplus.local, or http://192.168.1.240, or are you saying that this has also stopped working? If you can, please post a screenshot of the admin web page that you see.

All text referencing SW version is old. I cannot see my Nucleus+ in order to update. I got the version and build info on the installed apps page on my PC settings “Apps & features” page. The rest is outdated and I probably should have left it off, but didn’t know if it was helpful or not. Apparently not.

I tried to using the links provided to access the admin page, but all failed. I did a network ping to 192.168.1.240 and it failed so that must not be the address.

Hmmm OK. The issue where current remotes were crashing if the Roon Server software on the Nucleus was outdated could be fixed by going to the http page and clicking the Reinstall button for the Operating System, which would trigger the update for Roon Server as well. However, as you can’t get there this is moot anyway.

I guess it is a good sign that both the ping and ARC are working as this indicates that a) the Nucleus is still reachable on the network and b) working well enough for ARC to work. At least you don’t seem to be a victim of a broken SSD or Nucleus motherboard.

Questions:

First, I am confused by this - in the first post you wrote

and now:

Did you really get different results at first and now?
Anyway, the admin page of your router should show all devices that are connected on the network. Pls go there and find the IP address that it has assigned to the Nucleus.

Second question:

If you go to http://nucleusplus or http://nucleusplus.local, what exactly is the error message shown by the browser?

Third, you wrote that after reinstalling the remote on PC does not work and freezes. OK. But what about the other remotes on Samsung Galaxy TabS tablet and Samsung Galaxy S22+ mobile - you wrote that they are not functioning, but in which way? Not starting, crashing, freezing, error messages?

Won’t bother with the details, but I found the Nuc+ admin page…Now what?

The PC remote loads and immediately closes. I can see the message “Update Available” but the app shuts down immediately.
The S22+ freezes with the Update available for one or more of your devices message. The app does not respond to any command.
IP address of Nuc+ is 192.168.0.234. I have the admin page up and running. Tried to upload an image, but not sure if you can open. If not, how do I load a screen capture image?

Your Nucleus screenshot is showing it is running Roon Server Software B1128 and not either Production Build 1223 or earlyaccess Build 1228. You need to update your Nucleus first. Are you able to do that with the dropdown options listed?

That’s great, progress!

Edit: ah I see the screenshot now. What @Robert_F said

@Tom_Spaur clicking Reinstall for Operating System should normally trigger the update of the Roon Server software to the current one (build 1223), which should fix the remote crashes

Bizzare - now that I loaded by IP address both http:// options bring up the same admin page???

Roon Server Software drop down has two options: “Restart” and “Stop” No “update” option.

Which both http addresses? http://nucleusplus.local and http://nucleusplus is normal, the .local is just a more precise specification that is usually not necessary but is in some networks. Both IP addresses in the http with the same result would be weird because every device should have only one IP address and it must be unique - in this case something weird is going on in your router setup

That’s why I wrote and arrowed “click Reinstall for Operating System:slight_smile: This should trigger the update of the Roon Server software as well. It has helped countless times with this outdated Nucleus issue recently

Reinstalling now…Update in progress

1 Like

Update successful. Both PC and Android apps working. Back to listening! Thanks to all!

1 Like

One thing I don’t understand, when updates are available I always select “Update All.” So I don’t understand how things get out of sync?

Great, congrats! When you have a thought to spare, you should still figure out that weird IP issue, to avoid danger of future problems. Might your cable modem and the router both hand out IP addresses by DHCP? Only one should.

Good to know. That’s one question that is so far unclear. It does look like some Nucleuses simply got stuck on an older build without fault of the user. Which went unnoticed for a long time, until by chance the recent remote versions started crashing when they encountered older Roon Server builds.

Roon support wrote in other threads about this that Roon is investigating. Until we are sure that this is resolved, I’d recommend checking after the update that the build number did in fact increase.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.