Roon Remote does not connect to Roon Core

Core Machine (Operating system/System info/Roon build number)

Roon Core is in my Desktop PC, Windows 10 Pro, 64-bit, version 1709
Roon Remote is in my iPadPro software version 12.2

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Desktop connected via Ethernet ( to Router ASUS RT-AC88U
iPad Pro connected via WI-Fi (

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Audio plays via ethernet connected ( roon ready Cary Audio DMS-500, which passed its signals to pre-amplifier Anthem AVM-60 (also ethernet connected).

Description Of Issue

Roon Remote will not connect to Roon Core. Sometimes it says “Connecting”, then “Connection failed”, and keep repeating it. Other times it says “Looking for your Roon Core” and stays there forever.
I disabled Norton Antivirus, but made no difference.

Have you tried the suggestions in this guide?

1 Like

Yes, thanks. That was the first thing I did.

Have you checked this?
From Networking Best Practices:

ASUS Routers

We recommend enabling “Enable Multicast Routing” option in settings.

1 Like

Hi @Ignacio_Arribas,

Has this worked for you previously or has this remote never connected?

Have you tried rebooting your Core machine and the iPad remote?

I also recommend trying the above as BlackJack mentioned.

Tried all of the above. Still no luck.
It did work once. No changes in my system, except an update to the iPad software
Do I need to add some Port Forwarding?

You can try to click on help and enter as ip-address for you core.

If that doesn’t help, you might want to try another router. From another thread:

I had that bridge plus the “matching “ router RT AC 88U

After 3 routers and 2 Bridges I gave up and Asus couldn’t help, they found issues and changed devices but to no avail

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.