Roon Remote for iOS is Frozen after iOS 16 and Roon 2.0 updates

Roon Core Machine

RoonOS 1.0 (build 227)
stable/ Version 2.0 (build1128) production

Networking Gear & Setup Details

Connected via ethernet to Netgate/pfSense router. No VPN

Description of Issue

Roon Remote app (2.0 app, latest from App Store) is permanently frozen on my iPhone running iOS16.0.1.

I successfully ran the upgrade to 2.0 yesterday and the new Roon Arc app is working fine. However, the Roon Remote 2.0 app launches to the Home Screen and freezes before crashing. This is the first time using it since upgrading to iOS 16 so can’t isolate if that or the 2.0 upgrade is a root cause. I’ve tried:

  • Force quitting and restarting
  • Enabling “Reset Roon Remote” in Settings and restarting. I get the welcome screen and see my Roon Core as “Ready”. Attempting to connect goes to Home Screen and freezes
  • Deleting and re-installing app. Still freezes
  • Enabled logs, nothing remarkable that I can see

Ping. Still frozen and unusable.

If there is another support channel I should be using, please let me know. Going on 10 days without being able to use my service.

I’ve tried rebooting and re-installing on my phone and my Nucleus+, no luck. Verified that Roon Core and mobile app are on 2.0. Other devices work fine.

Delete Roon Remote from your phone and reinstall the latest 2.0 version from the Apple App Store.

Thanks Jim,
I’ve deleted and reinstalled the 2.0 app at least 10 times, no help. Sees the Core (Nucleus+) as “ready”, when I connect it freezes on home screen.

Can confirm Core and app are 2.0, and I’m on latest App Store release.

Hi @Alan_McConnell,

Thank you for your patience as the team worked through the queue. Diagnostics indicate that Roon has still been experiencing some network issues in your setup, so please accept my apologies that you’ve had to endure the symptoms described in your original post for this long.

Looking through logs, there’s sporadic disconnection of both your Mac and iPhone Remotes, as well as one of your networked endpoints (a Dragonfly DAC). These failures occur around the time of login authorization and other key processes after the Core boots up and after it first connects with a Remote, so it’s more than likely the networking issues are creating conditions for the freeze. It doesn’t appear that you have multiple subnets in operation, so the cause is likely in either your multicast binding settings or your DNS settings.

It’s likely you’ll have to open the web administration page for your router and toggle on/off multicast binding (there may be traffic filtering going on).

I also recommend you change the DNS server assignment in the Nucleus web administration page to one of the following servers: Cloudflare DNS or Google DNS. Can you please give this a try and let me know if it helps?

If these steps fail, we’ll want to start to eliminate variables in your local network to try to see where the upstream block might be (calls/requests both within your LAN and to the broader internet are failing from the Nucleus+). Do you have any additional managed switches, gateways, or access points in this setup other than your Netgate/pfSense router?

One other step - routine diagnostics aren’t reaching our server from your iPhone. At your convenience, would you mind supplying technical diagnostics to the team from your phone by following these instructions for iOS logs?

Thank you again for your patience and we’ll be watching for your response.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.