Roon remote not connecting to core

System set up: Roon Core on Innuos Zen Mini Mk III. Asos laptop running Windows 10 has remote APP installed, as do 2 tablets.

All was working fine until last 24 hours. Wireless router appears to have had a power outage.

Router now back on and working. Can see Zen Mini on my network and can also “ping” its IP address.

But every time I try to go through Roon remote app on laptop or tablet, message is that establishing connection to Core is taking longer than usual, and connection is never achieved.

Have also tried re-starting Innuos Zen Mini, and powering it on and off several times. Did the same to the router as well. Also uninstalled / reinstalled Roon App on laptop.

Anyone got any ideas how I can get this working again? Thanks.

Hi @David_Carter,

What kind of router are you using, can you list the model/manufacturer? Has anything with regard to “multicast” changed in your router config since the power outage?

To help separate if this is a networking issue - if you try to temporarily host your Roon core on the Windows PC, are you able to connect via your Roon Remotes?

Hello again Noris. Thanks for getting back to me.

OK. Let’s start with the router details:

Talk Talk DSL-3680 Broadband Wireless N150 ADSL 2+ Router. Hardware Version A1 Firmware Version v1.06t

That’s as much as I can see on the plate attached to it.

Not sure what multicast means. Have tried to look on Net, but we’re doing nothing here other than usual home usage with a laptop and router. Not a network with several different people attached to it.

All of that has been working fine with Roon / Innuos combination since last May, and also for a couple of days since the 2 recent updates to new version of Roon.

One thing I have noticed. Since the router went down and then came back, the IP address of my Innuos Zen Mini (which holds the Roon core) has changed. Would that make any difference? And if so, how do I get Roon to acknowledge the new IP address?

Another thought. When I download the Roon App again to my laptop, at no point am I asked to enter a login and password. Is that normal?

You mention trying to move the Roon Core temporarily to the laptop, rather than it being integrated within the Zen Mini. I’m not sure how to achieve that. And are there any implications size-wise for my laptop?

Thanks (and perplexed).


Hi @David_Carter,

Thanks for sharing those details, I have some feedback for you here:

Since this is an ISP-provided router, we have often seen poor performance surrounding similar devices, as mentioned in our Networking Best Practices Guide. Specifically, we have found that ISP routers often times do not pass multicast traffic through properly, and Roon relies on multicast to operate properly.

Multicast is a protocol that Roon uses for device/core discovery. You can read more about multicast here

No, the IP address change shouldn’t make a difference as long as multicast traffic is properly passing through. Roon should still automatically discover your Core if it is on the same network and same subnet range for IP addresses, meaning that both the Core and Remote/Client share the same IP except for the last 3 digits (e.g. 192.168.1.XXX).

If you have the Zen as the Core, this is ok since the laptop was just acting in remote mode until now. The login info should be cached.

If you have Roon installed on your laptop you can do this by going to Roon Settings -> General -> Disconnect. Once you are on the “Choose your Core” screen, instead of selecting the Innuous as a Core, you would need to press Use this PC. The Roon database does take up a bit of space, but depending on the amount of tracks on your laptop (which I would think is not that large), it should be under 30GB. We can remove this space once we finish testing.

I suggest we make two plans of action here:

  1. Upgrade the networking gear to something more modern, a consumer grade router from Asus/TP-Link/Linksys is suggested in place of your current router. The current router can be placed into “Modem” mode, where all it does is convert the ADSL incoming connection to Ethernet. I also suggest disabling the WiFi on the Talk Talk router and leaving just the new router to handle the network communication.

  2. I would try using the laptop as a Core to verify if the behavior is the same or if it is only occuring on the Innuous. You can use the above instructions I listed to make the change.

Thanks for those last thoughts Noris.

Having read it through, I wasn’t convinced the router was the problem. As I said before, it’s worked fine up to now.

Took a more radical approach. Disconnected Roon core from Innuos, then went right back through set up of system as if it were the first time ever.

Used Roon core integrated within Innuos Zen Mini. Then the Roon App on my remote laptop did connect to core.

Had to rebuild library from scratch from the music loaded and stored on the Zen Mini. All worked well again.

Only small issue I had was with Remote App on a Galaxy S3 tablet refusing to connect to core. But once I cleared the Roon App cache and reinstalled App on the Galaxy tab, that worked again as well.

So, a possible solution there to offer folk if they face a similar problem. Basically, disconnect Roon from its core, then put it back and rebuild.

Thanks again for your time and suggestions.

1 Like

Hi @David_Carter,

Thanks for the update here, glad to hear that rebuilding the Innuous Roon App resolved the issue for you!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.