Roon Remote on iPad Pro Spontaneously Quits


Running Roon Remote in 12.9" iPad Pro tablet 2017 model. Roon version 1.5 (build 360) (64 bit)

Roon Core running on Linux server from SmallGreenComputers. Roon Core version 1.5 (build 360) (64 bit)

Roon client on PC Roon Version 1.5 (build 360) (64 bit)

Everything was running fine and stable until an event I’ll describe below.

The current problem: Roon Remote performs many quick “Awaiting Connection” screens that come and go. And then it just spontaneously exits. Sometimes it just exits before doing “Awaiting Connection” screens, sometimes after a bunch of “Awaiting Connection” screens–there is no pattern.

The weird thing is the Roon Remote icon is still in the recently used apps section of the dock and nothing—including a reboot–can dislodge it. The dock icon no longer works to bring up Roon Remote also; it is inactive and grayed out. It doesn’t operate even when Roon Remote is a background app that can be brought forward.

I tried uninstalling/reinstalling Roon Remote and that didn’t do anything for the problem with quitting. Uninstalling/reinstalling will dislodge the app icon from the dock though. After the reinstall, the app icon on the dock is still stuck like before and doesn’t operate–even before the Roon Remote app does it’s first spontaneous exit.

This problem started when I had the iPad Pro Roon Remote open to the Artists | Elton John screen, and I had my PC version of Roon open to the same screen. On the PC Roon screen, I selected 2 albums and I did Edit | Group Alternate Versions. At that point, the albums were grouped on the PC Roon, and at that moment the Roon Remote on the iPad Pro exited spontaneously. And it hasn’t worked right since.

Roon Remote on my iPhone X still works fine. I just need it to work on my iPad. Help!

Greg Burns

Hi @Greg_Burns,

Let’s try to do a reset on the iPad and see if there is any change here:

  1. Hold down the home and on/off buttons at the same time.
  2. Continue holding the buttons even after the slider appears on the screen. The screen will eventually go black.
  3. When the Apple logo appears, let go of the buttons and let the iPad start up like normal.

Let me know if you’re still seeing this behavior after the reset.

I reset the iPad to factory (fresh) and loaded an older backup. The Roon Remote app no longer has a stuck icon and can be brought to the foreground from the dock now.

However, the Roon Remote app is still unexpectedly exiting. Randomly. All the time.

Now other clients are failing also. Windows 10 client is exiting unexpectedly. I rebooted the server, but I am wondering if the Roon database is corrupt. I only used Roon for 45 minutes total. Sigh.

Hi @Greg_Burns,

Can you describe your current networking setup including all networking hardware in use and how your devices are connected?

When the iOS remote is unable to connect can you try using an app like Fing that scans the network and see if the remote is able to detect the Core machine on the network?