Roon Remote on iPhone 12 frozen after successful connection to Core

Roon Core Machine

ROCK Version 1.0 (build 227) stable on NUC (Intel i7)
Roon software Version 1.8 (build 831) stable

Networking Gear & Setup Details

Netgear Orbi with latest firmware
NUC, PS Audio DirectStream DAC, and Mac hardwired into router.

Connected Audio Devices

PS Audio DirectStream DAC, Mac (with iFi Pro iDSD DAC via USB)
On Wifi: iPad Mini 6, and new iPhone 12, both running iOS 15.1.1

Number of Tracks in Library

More than 10,000

Description of Issue

Roon Remote app on my iPhone 12 installs fine, then finds my Roon Server fine—it sees the NUC and I am able to connect to it. See the screenshot of the Audio tab in Settings, which shows the three Zones enabled and connected.

But after connecting to my Core, the Roon Remote app on the iPhone 12 freezes on the screen that says “Hi, Michael” with “Select an Audio Zone” button. Nothing I do in the UI causes a reaction—not the Select Audio Zone button, not the menu on upper left, not the search icon on the upper right. iOS itself is responsive—I can swipe the app up and away, etc., but the app itself is toast.

  1. I didn’t have this issue with my former iPhone (an iPhone 8, yuck).

  2. I don’t have this issue on the iPad mini 6. Roon Remote works fine there.

  3. I don’t have this issue on the Roon app on the Mac.

I’ve tried uninstalling, rebooting and reinstalling the Roon Remote on the iPhone 12 numerous times. I read someone remark that for some reason it makes a difference if the Roon profile has a birthdate. I’ve made sure it does. I’ve restarted the Roon Rock NUC. Nothing makes a difference.

I can use my Roon at home using the iPad as the remote, sure. But it’s very annoying that the software doesn’t work the way it’s supposed to. Sometimes I just want to use my phone to drive the system. My phone is always with me, the iPad not always. Please help!

Hey @Michael_Fuchs,

Please, accept our most sincere apologies for the delay in getting back to you. We’re most appreciative of your detailed description of the issue and all the troubleshooting steps you’ve tried.

Right before taking this to our technical team, I was wondering if you could please check the iOS permissions on your iPhone, as explained here: