Roon Remote on Windows 11 PC Crashes on startup

Roon Core Machine

Roon Core is on Nucleus+

Networking Gear & Setup Details

PC and Nucleus+ connected to ASUS router via ethernet. IPad connected via WIFI

Connected Audio Devices

Sonore Optical Rendu

Number of Tracks in Library

1352 Albums

Description of Issue

Roon Remote on Windows 11 PC crashes on startup, that is, the Roon Window displays for about 1/2 second and then closes immediately. There are no error messages that I can see. Roon remote still works fine from my IPad. This issue just started today. I have been running Roon Remote from the PC for many months previously without issue.

One solution would be to delete Roon from the PC and reinstall. Might be an easy fix since it’s just a remote, not a Roon core.

There may be other solutions as well.

I did try to Reinstall the Roon software, although I did not delete it first if that makes a difference.

I have also rebooted both the PC and the Nucleus+

I also disabled the Firewall on the PC and reinstalled the Graphics drivers as the Troubleshooting guide recommended.

This happened to me once and I deleted Roon from my laptop and reinstalled. That fixed it.

I tried the uninstall / reinstall method. That made no difference.

How do you get Roon Technical Support? I thought posting here was the process for requesting Technical Support. Does it just take awhile for someone to get back to you?

Posting in the #support category automatically notifies the Support team. However, the team is just four people, and they have a queue of support requests to deal with, so it can take some time before they are able to respond to an individual request.

That’s why it can be useful for other Community members to try and help.

You say you’ve disabled the Firewall on your PC. I hope that you have now turned it back on.

Are there any relevant messages being shown in the Windows Event Viewer?

I did disable the Firewall. I haven’t turned it back on yet.

There are no error messages displayed. The normal Roon Remote window opens for about 1/2 second and then disappears.

I do think I had a Windows Auto-update that occurred inbetween the last time that the Roon Remote worked and then not working. So, it seems quite likely that something in that update has caused the Roon Remote to no longer function, but I have no idea of what that might be.

Please turn your Firewall back on :slightly_smiling_face:

I wasn’t talking about error messages displayed on the screen - I meant are there any relevant messages being shown in Windows Event Viewer?

Look in the Windows Logs > Application section and filter on “Error” events…

Looking under Windows Logs → Application in Event Viewer I am not seeing anything Relevant to Roon. A few ATIeRecord failures but it looks like they go back longer than I have been having the issue with Roon.

No one from Tech Support ever bothered to contact me regarding my issue with Roon crashing on startup.

However, there is another thread where several people were experiencing the same issue on their Mac devices. Tech Support did respond to that thread and the root cause was identified as a stalled update on the Roon Core (versioin 1148) while the Roon Remote had been updated to 1211. The recommended fix was to use another Roon Remote device to force an update on the Roon Core to 1211.

Ironically, I did not have an issue with Roon Remote on my Ipad, it was my PC Roon Remote that was crashing. However the fix suggested on the Mac thread, did fix my issue. Luckily, I had an Ipad with Roon Remote that was still functioning, and I was able to force the Roon Core update. Once the Core was updated to Roon 1211, my PC Roon Remote worked again.

I am still disappointed that no one from Roon Tech Support ever responded to me or my thread to help me fix my issue. When you pay for a subscription service, I guess I expect better Tech Support. But I am thankful for the rest of Roon Community as reading other peoples problems did help me fix mine.

Mac Thread:
Roon Crashes Immediately on Startup (MB PRO M2, Ventura OS) [Investigating - Ticket in, workaround in comments] - Support - Roon Labs Community

Hi @Phil_Raftis,

I was the one handling the reports from users in the thread you provided. We had no reason to believe that Windows machines were affected by this problem so in filtering and triaging the reports, your report would have not been obviously tied to the link you shared.

We haven’t had a chance to yet is why. It’s not for lack of concern or empathy and that I can assure you of. We do our best.

I do want to express appreciation to you her. I will share with my teams that the issue isn’t exclusive to macOS. This will help tremendously.


One additional piece of information that may or may not be relevent to you, I believe that the attempt to update my Roon Core occurred about 2 or 3 weeks ago. Ever since that failed update attempt, when I would start up the Roon Remote (mostly on PC), I would get the pop-up saying that software updates were available for one or more devices. I would always select the update button, but it doesn’t seem like anything ever updated, and I would continue to get the update pop-up every single time that I started the Roon Remote. This continued on for 2 or 3 weeks until 2/16 when the Roon Remote on my PC would crash on start up. If I started the Roon Remote on my IPad, I continued to get the update pop-up. After I forced the update on the Roon Core, then the pop-up stopped coming up and the PC Roon Remote started working.

One other thing, the directions to force the update on the Roon Core only mentions forcing the update. I had to force the install as well. The Install did not happen automatically after the update completed.

I don’t like automatic updates, so I turn them off. When I get a message that a Roon update is available, I go to Roon - Settings - About and click on update there, when I’m not busy doing something else. I then also update any Roon clients that need updating. Works for me.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.