Roon Remote screen redraw problems with MacOS Ventura 13.1

I use Roon Core (2.0 1182) on an Audiolinux Custom built server, and Roon bridge on a variety of devices including custom built NUCs and a Microrendu. I use a variety of different devices for Roon Remote including several Macs running various versions of the MacOS and an Android phone and Tablet.

Recently I’ve updated my work computers (a Mac Studio and a 14" Macbook Pro) to Mac OS Ventura 13.1. Since doing that I’m having screen redraw problems with Roon Remote (also 2.0 1182) on both machines. The Roon screen is constantly redrawing and it is relatively unusable. The same thing happened with 13.0. I did not have this problem with these computers running Monterey. Roon remote is still working fine on my Mac 2012 Mac Mini and 2013 Macbook Pro that are both using Catalina and my Android devices. Looks like an Roon update will be necessary to address the problem.

I’m happy to provide a screen capture video if you would like to see what is happening.

1 Like

Please do. No problems on my 16" MacBook Pro (2019 Intel) with Ventura 13.1 running Roon Remote (2.0 1182).

Here’s an example of what is happening on the Mac Studio. Both computers are M1 Max processors, so Apple Silicon.

The same thing on the Macbook Pro, both running Ventura 13.1.

Everything working normally on Catalina Macs including a Mac Mini and another Macbook Pro. Everything is connected to the same network.

This example is for a local file, but exactly the same thing is happening when I use Tidal or Qoboz.

Internet on both of these machines is working normally with very high down and upload speeds.

It appears what is happening is that Roon Remote is loosing it’s connection to the Core.


@zomtel, thank you for the video, this is helpful. Based on what I see, this is not a screen refresh issue on the Mac, but rather the Core and the Mac Remote are losing their connectivity; this occurs at 2-3 seconds in, again at 6-7 seconds, then 11-12 seconds, and so on. Your Mac Remote is searching and then finding the Core on your Audiolinux server, indicating most likely a network issue somewhere in your home LAN.

Can you provide additional information on how your home LAN is configured, including what components are wired and what are using WiFi, your home network equipment, and any other information that Roon and the Community may need to help assess what you are experiencing?

1 Like

I have ZERO problems running Roon Remote 2.0 in my Mac Studio M1 Max running macOS Ventura 13.1. Like Robert_f mentioned, that looks like a network issue more than a Roon Remote issue.

I have a TP-Link AX11000 MU-MIMO Tri-Band Gaming Router with a network extender at the core. One band is dedicated for Roon. The core is hardwired to the network extender while all the devices I mentioned are on the same wireless network. The mac studio has both a wireless and a wired connection, with the wired favored. As I mentioned only the Ventura 13.1 devices are having problems. Everything else is working fine on the same network. These two computers that are now having problems with Ventura were both working fine with Monterey.

Some additional questions:

  1. How is the network extender connected to the router, via a wireless mesh interface or via an Ethernet cable?

  2. Is your wireless band dedicated to Roon one of the two 5GHz bands or the 2.4GHz band?

  3. Why does the Studio have both a wired and wireless connection? Are both of these active? To what is the Studio’s wired connection attached?

  4. Is the MBPro using WiFi?

  1. Wireless…not a mesh…it’s a Netgear Repeater which I’ve been using in this exact configuration for years (I’m a Roon charter member).

  2. 5GhZ

  3. Both are active, but the Wired is favored. I’ve tried dropping either connection with the same results. The Studio can work fine with this configuration which I also used with Monterey.

  4. Yes MBPro is on wireless. Currently so is the Studio, I turned off the wired connection. Both of the other Catalina devices are also on wireless.

What I just noticed is that the problem is created when I’m logged into Roon on both Ventura devices. When I quite Roon on the laptop the studio appears to be fine. Likewise if I shut Roon down on the studio and open Roon on the laptop, no problem Note that two other copies of roon remote are active on other computers (both Catalina) when this is happening, so pre-Ventura this wasn’t a problem. Thus this might be a Ventura network problem sharing the core across two Ventura devices, if this makes any sense.

I have 5 Roon Bridges (one physically connected to the server via fiber, one microrendu, two NUCs and a Chromcast audio) in my house and have devices in most rooms for control.

I am wondering if the dual network connection may be having an unintended consequence of IP addressing within Roon. If you run Roon on the Studio via WiFi only, and keep Roon open on the MBPro using WiFi, does the problem persist?

No difference. I cut the second connection to the studio so both the studio and the MBP are only on wireless and if I have roon open on both Ventura devices I get the problem. If I only have it open on one or the other, no problem. Same is true if I use the wired connection on the studio and wireless on the MBP. Note I didn’t change anything about my network or the way the computers were connected to the network when I upgraded to Ventura.

It’s getting late for me but one last attempt tonight. Can you hardwire your Core directly to the TP-Link router, leaving WiFi for your Studio and MBPro?

It’s about 100 ft away…let me see if I have a really long ethernet cable…but I wouldn’t be able to do this routinely.

No, I don’t have a cable that will stretch that distance. I think this is an issue for Roon tech support. Looks like something they should be able to reproduce on their end. Just get two Ventura devices on the same network connected to a separate core and I bet they will get the problem. Looks like there was a change in the Ventura network protocol that Roon is not compatible with. Obviously many people would not have this problem…but I have a lot of endpoints and a lot of devices running Roon. I might consider backgrading my laptop to Monterey as I haven’t seen anything in Ventura that is really useful…Apple is just treading water on OS’s these days.

I don’t think they will. Just as a data point: I have up to 5 MacBooks around the house (M1/M2), all running Ventura, oftentimes simultaneously. At the moment I have two MacBooks running Roon side-by-side without as much as a hiccup.

Wiring up your Core (even temporarily) however will greatly help the troubleshooting process.

1 Like

Hi @zorntel,

My apologies for the slow response from Roon support here. I’ve read through your thread and would concur with others who pointed out the losing connection to core issue at play.

Is this still happening? If so, can you give me a date and time of any such instance so I can review things in the logs and offer my advice?


Any progress/solution to the issue?

I’m still having the problem, but I have more details. The problem only happens when I have two computers running Ventura on the network. This includes Ventura 13.2.1 The number of pre-Ventura machines doesn’t matter, but as soon as I open Roon on two Ventura macs the Roon connections on both machines start dropping. All other connections to the Roon Server from other Roon remotes (Non-Ventura Mac, Windows, Android, and IOS) are fine and any tracks started on the server from the problem machines play fine, the Roon remote displays on both Ventura macs just keep losing their connection and try to reconnect. This ends as soon as I close Roon on either machine.

Just happened a few minutes ago when I tried to open Roon on my Macbook Pro while roon was already running on my Mac Studio. Both machines running Roon on Ventura 13.2.1

Hi @zorntel,

My apologies for the slow response. I have been unexpectedly out of the office.

I appreciate you getting back to me but can you please supply a date and time? There are no time-stamps in community aside from the number of days.


Now it’s my turn to apologize for the slow response. 27 days ago was around 2/24 and I think it was in the late afternoon, early evening CST. I’m not near my system, but I can make the problem happen any time you want when I am. All I have to do is open Roon on two computers running Ventura. The number running earlier versions of the MacOS (or Windows) doesn’t matter.