Roon remote unable to login to

Core Machine (Operating system/System info/Roon build number)

Serial #94C691ACBAFA

Rock NUC 8i3BE in Akasa Plato X8, 8GB RAM, 256GB SSD, 1TB internal storage SSD, LAN, WiFi dongle;
Roon Server 1.6 (build 401), OS 1.0 (174);

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Raat: 192.168.3.x internal LAN (direct LAN cable to SOtM200), Rock and SOtM200 in fix IP.
devices: WiFi 192.168.1.x ROCK and SOtM200 in fix IP.
Control: laptop, Samsung phone
Router: TpLink Archer C7, 1Gbit

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

SOtM200 (LAN+ Wifi dongle)

Description Of Issue

In on the 60 day trial period (before annual payment), Roon almost worked perfectly (sometimes unable to send music to SOtM) till last evening.

The Roon control devices (both laptop and phone) after connecting to ROCK begins with login window.
After login (in the same laptop I’m logged in to roonlabs where " Your trial is valid through May 12, 2019" ), the error: "Network error: Please check your internet connection).

The error is the same in the phone control.

Roon normally requires all devices to be on the same subnet

also double check your DSN and gateway settings if you are using fixed/static IP addresses

post your screen shots here of the above if you like

Hi @Bela_Nagy,

Since experiencing this issue have you tried rebooting your ROCK device?

If you connect your laptop to the network via Ethernet in the same place that the ROCK Core is connected, and you try to login using the laptop as the Core, do you see the same error?

Hi all,

ROCK and SOtM is in 192.168.3.x LAN subnet, both fixed IP.
Both of them has WiFi dongle in 192.168.1.x subnet (fix IP).
My main router and WiFi control devices (laptop, phone) also in the x.x.1.x subnet.

About few weeks ago I ported ROCK (and SOtM) from the x.x.1.x subnet to x.x.3.x subnet, and supplemented both with WiFi dongle (x.x.1.x subnet) for control.
In the Raat subnet the the gateway and DNS also
All was working as before, till last evening.

I “see” ROCK and SOtM attached libraries (in x.x.1.x subnet).

Last evening I rebooted ROCK sometimes, but the symptom is the same:
in my control devices the Roon requires login, but negotiate it.

Not having dns and gateway entries is probably a good place start putting in some appropriate values

ROCK and SOtM connected together via LAN cable (no switch, no router) in x.x.3.x subnet (static IP, subnet, as gateway and DNS).
Both of them has WiFi connection (static IP), where gateway is the main router and DNS is

As I wrote it was working.

I would suggest going back to dhcp on the rock and anything else in the setup that’s currently fixed and going back to fully wired for what you can all on the same subnet including your WiFi remotes. If that works (logging in on a remote is via the core’s internet connection) then you can start looking at what’s not right with the network changes you made. Is there some specific reason not to run one network?

You are making troubleshooting complicated with a split network setup and dongles that might not be fully supported.

Then update the rock core to 416 while you are at it.

Now I “rebuilt” mini network:
ROCK and SOtM connected via x.x.3.x router. This router routed to x.x.1.x (internet). Laptop connected to x.x.3.x net via WiFi.

Roon required login, and after it refreshed Roon software, and now working … Hallelujah :slight_smile:

But … I want separated Raat network (x.x.3.x) without router and internet access, because both ROCK and SOtM has internet access (x.x.1.x) and all of my control devices in there.

I hate to load my networks unnecessary traffic.
Traffic errors -variable delay, collision- between Roon server and endpoints determines music quality, so I don’t want mix audio packets with “general” LAN traffic.

Now 15m LAN cable coils like a snake through the building. :frowning:
This is “fire extinguish”, but not a solution.

I don’t understand if the ROCK (linux!!!) capable to use WiFi, why must accumulate all devices in one (LAN?) segment?

I have my core and many endpoints plus 2 nas and many workstations all on one network with no issues. You seem to making life difficult for yourself…enjoy the music now that you know it’s your networking setup issues you need to solve.

And what about this?

Maybe it’s worked for some but however you have tried to do it it’s not working. I guess it’s up to Roon as to how they progress this issue you seem to having but it works as it is primarily designed so like others have said I too think this belongs in tinkering.


It’s working (Roon server send music to endpoint for weeks almost flawlessly -sometimes occurring error due to SOtM- ), but -in my opinion- don’t recognise, that internet connection is in the “second” ethernet device -wlan0: WiFi- (not the eth0 as at installation), so after a considerable time stopping (no licence?).

Is possible to install ROCK with WiFi dongle as “primary” ethernet device?

perhaps I should rephrase that then…how you have tried to do it is not working for you.

OK, in your opinion this way is dead end (ROCK install unalterable?)… but how this will working?
Buying USB_to_Ethernet dongle and send over there Raat packets (up to DSD 512) to the endpoint, instead of using gigabit Ethernet port?

I suggest you go with what has been tried and tested to work, if that is a Usb to Ethernet then try that. I’m not the rock systems developer nor do I have your models of equipment and setup to test. I’m just trying to assist you getting a working setup as is normally used, anything else you have to tinker about with as it’s not in the mainstream of normal use.

If Danny thinks he can add something to help you I’m sure he will do so, as may other support folks and others who might have done similar things.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.