Roon remote won't connect TP-LINK Deco S4 Mesh

Lenovo YOGA 900, I5, 8 GB RAM, Windows 10 64 bit connected via WiFi.
Samsung Galaxy Tab S7, Android 11 connected via WiFi.

Networking Gear & Setup Details

TP-LINK Deco S4, Mesh network, running as wireless router,

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I can not run AP as I have no way of connecting via cable.
I used to run a traditional Netgear router, with no isues, other than poor coverage.

After setting up the TP-LINK I can not connect to the core.

I have tried what I could find on the forum without luck, including static IP, etc.

Both devices are connected to the same node.

Hi @Claus_Olsen,

Thank you for getting in touch with your question and welcome to Roon Community! We’d be happy to help with this.

Let’s start by Rebooting your Roon Core, Router, and your Roon Remotes. What’s probably happening here is that Roon has retained the old IP address. The restart should help clear this up. Additionally, check to ensure that IPv6 is disabled in your TP-Link app settings, we’ve seen that cause issues like you’re seeing.

Please let us know if this helps. Thanks!

Rebooting dosn’t solve anything.
IPv6 is disabled.
Even when I enter the IP adress for my computer (Roon core), it can’t find the remote.
I’ve looked through countless post on the forum, with no luck.
The closest I get to an answer is that I should run the router in AP mode, but that defies the point of getting a Mesh network.
AND I have no way of connecting my AP points other than via cable, witch is not possible.
I am know very frustrated. This is an expensive subscription, but without the remote, it’s not giving me all the functionallity thar i’m paying for.
The TP-LINK Deco is one of the most common Mesh network solutions out there, and should work with Roon without any hassle…
Please help?

Claus, how is your network configured? For example:

Internet modem → Ethernet cable to Deco S4 primary router → WiFi to other Deco S4 mesh devices?

If so, the first Deco S4 device that connects to your modem must be configured as a router, unless you have a router that you are using already. Then the first Deco must be connected to that router also by Ethernet, and then used in AP mode or possibly in router mode, but it depends on how you want your home network to operate.

Hey @Claus_Olsen,

I’m sorry to see that you were still having issues. Was @Robert_F’s recommendation able to help? I’m hopeful that’s the case. In checking your system diagnostics it appears that you were able to connect shortly after he posted.

Please send us an update when you can. I’ll be watching for your reply. Thanks!

1 Like

Hi @Robert_F
I’ts configured as a router, connected to an internet modem.
Then there a to more nodes working in a mesh system.
But even when I disconnect the nodes, it can’t find the core. I even tried the correct IP adress to no avail…
When I connect my old router it works again…
It’s quite frustrating to say the least😔

Hi @jamie
No it hasn’t worked yet.

Are you sure the Roon core IP is in the same range as the Mesh system? For example, when i had only my ISP router my IP were but when i connected the router to a Mesh system the IPs of the Mesh were i couldnt find roon because for some reason Roon core kept the old IP, in my case As soon i changed to core to all my devices found Roon right away.
Mesh system configured as Router, connected to the internet provider router via ethernet. Roon core connected to a second mesh via ethernet, but via wireless works as well.

1 Like

I agree with Bruno, this seems to be two different networks. Are you connected to the TP-LINK network? Do all of you devices, wired or wireless, show up in the TP-LINK administration or network devices list or page?

Can you determine the IP address for any of your Roon remote devices connecting on WiFi? Can you also determine the IP address of your Core?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.