Roon Remotes Refreshing/Loading/Losing Connection with Roon Core after Apple Migration Assistant

Roon Core Machine

Apple Mac Mini 2012, Intel CPU, 16GB RAM, SSD

Networking Gear & Setup Details

Modem → Eero router → Netgear GS108 unmanaged network switch → Roon Core (chain is connected via ethernet)
Roon remotes connected via WiFi

Connected Audio Devices

Kef LS50 Wireless II connected via WiFI

Number of Tracks in Library

~10,000 tracks

Description of Issue

My setup has been operating flawlessly for years until yesterday, when I retired an old 2015 intel-based Macbook Pro and performed an Apple migration using Migration Assistant to a new Apple Macbook Air M2.

The migration was actually from a 2019 intel-based iMac (which also serves as a roon remote) and not the retired laptop.

After the migration, when I have roon software opened on both the new Macbook Air M2 and the 2019 iMac, roon continuously refreshes/loads to the point where both computers are losing connection to the roon core and trying to reconnect. As soon as I close either instance of roon, the remaining open roon software recovers. Playback is not affected during this, but the roon remote software is unresponsive due to the constant refreshing.

Please help! Thanks in advance!

Hi Chris, fellow user here
Sorry you have troubles and while I do not know if I can help maybe some other users already have seen something like your problem.

Disclaimer aside,
First idea: while migrating with apple is nice with roon it does not behave so nice (this is specially for core but maybe for remotes also). So you can try delete roon app and install a new one on your remote machines. (maybe you tried that)
Second: you should check that all installed versions are up to date.
3th: maybe try to turn off airplay and handoff from system settings. Sometime that can cause errors but not like yours
4th: (hope it is not the case): I’ve seen people complaining about their outputs not being in the roon settings. The issue resolved as soon as they made different user names for both machines. Again nothing like your problem but you never know.

That’s because Time Machine may back up a live database and thereby create inconsistent states


Backups should be done by Roon’s built-in backup tool (and simply be excluded from Time Machine backups as those are useless in this case)

Then make a fresh install of Roon on the new machine and restore from the Roon backup

1 Like

Yes but he did not touch the core from my understanding, just the comps that he uses as remotes. But was my guess that maybe roon used only as remotes can also have this problem with migration assistant

Thanks for the suggestions. I did try reinstalling roon on both roon remote machines (macbook air and imac), and that did not resolve the issue. All machines have latested versions installed. I’ll look into the airplay/handoff suggestion.

Does your suggestion still apply here if I did not change the machine running the roon core?

I was afraid of that answer :frowning:

Unfortunately I cannot replicate your situation as I have only on remote, on an iMac and the mini core.

Have you tried to turn down all firewalls? Does roon have full disk access on all of them. I’m popping ideas in the hope on not trying different users on iMac and MBA. Maybe try and disable the Apple ID on one of them.

Sorry, I missed that this was not your Core machine that you migrated.

Nevertheless, even a remote will have a program state that is saved in files on the remote’s machine, and maybe this can be backed up in an inconsistent state as well if the backup is made while the remote is running. There is not very much lost when doing a fresh install of a remote, and I don’t know if it’s worth backing up. Though I have to admit I’m not sure if import settings, which can be quite complex, are saved on the core or in the remote. I would guess the core, but have not tried this.

You can try uninstalling Roon on the new machine and then deleting the migrated program folder that contains the info of the Roon remote. Reinstalling Roon alone is probably not enough as I don’t think this program folder is deleted by this. All this saved Roon info that belongs to the remote should be in your user account’s applications library folder, User > Your username > Library > Roon. Try moving this to a different place (to have a backup just in case), create a fresh Roon install, and redo your remote settings.

The user library folder is hidden by default and you can make it visible as described here:

1 Like

Solution found. I used the erased all data and settings feature on the new MacBook Air and reinstalled everything without using the migration assistant. Everything is working great now. I learned to never use the migration assistant and just install everything manually when switching out old Macs! Thanks for everyone’s help.


I hope it was not too painful to reinstall. Glad that is working.
Happy listening.

It was actually easier to setup the new MacBook manually rather than with the migration assistant. Go figure!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.