Roon Remotes won't see Roon Core

Room Remotes (on my Android Devices) can no longer find my Roon Core, Ive checked many things nothing has fixed the issue, please read through and then see if you can help with something I haven’t tried

I’ve had to replace my WiFi router, with the same make and model, basically a drop in replacement, with all my Wifi settings copied over, so SSID and passwords are all the same, everything around the house is connecting fine, including Chromecasts, Nest thermostat Ring Door and countless wired and wirless network devices, All good after router swap… except Roon Remote.

My music sits (ripped and downloaded) on a NAS drive and I run Roon Core on a Windows PC, both of these are using wired connections, all wired devices are working fine, I can playback audio to any of several zones around the house. Most of my endpoints are connected over Wifi, the WiFi is fine, the wired network is fine.

But Roon Remote won’t find the Roon Core at all. I tried it on an Android phone and a tablet, both connected to the same network via WiFi and both used regularly on a daily basis before for more than a year, no issues.

The same Android devices are able to find, stream, and cast the same content using Plex (the same Windows PC running the Plex server and serving the same content

Things I have tried checked include the following:
Deinstall and reinstall Roon Remote
Checked IP address of the PC running Roon Core (it is un changed and in fact is the very same IP address that Roon Remote is scanning for,
Complete hardware restart of the PC running core
And another restart of the router
Connect the Android devices only to 2.4GHz WiFi

All hardware and software unchanged apart from BT Router swap out.
Roon Core version 1.8, built 806 64bit
Windows Version: Win 10 Pro 64bit, official copy license key activated
Roon Remote version also described as 1.8 (build 806)

Any ideas? how do I get support on this topic…

empty (network address) cashes on your android remote?

1 Like

tried that, it didn’t fix it, how do i get support on this topic?

Friendly Fellow user, if you cannot attach to the Core with the android device, click the blue Help link on the can’t find server page; which opens up an option to enter the server IP address, try; and then see if it connects.

Another possibility is windows update had changed something like firewall is now on or network settings changes to the interface like private or public etc. this is where I would focus

Also try an app like FING on your mobile devices to see if they can see the core pc address listed, and ping it.

I am using the McAfee edition that is enabled “in price” by my router from BT (British Telecom) I’ve been using it for years, since before I had Roon,
Anyway on turning off the firewall it does indeed unblock Roon Remote, so the Firewall is the issue
Not being a firewall expert, are they any tips as to which menu I go in to, what setting do I change, to be able to tell the firewall NOT to block Roon Remote

You need to allow exemptions for Roon, RoonServer, Raatserver.

Can you be a bit more specific and tell me how to do that? under which of the menus in the screenshot above would I find where to set that up?

perhaps firewall history might say what is being blocked and allow some options?

Failing that support from the people who provide the device - is that BT?

maybe click on Learn More?

Hi @Guy_Gampell2

To start, I’d recommend disabling McAfee and Windows Defender Firewall temporarily, just to see if that results in any change. You’ll want to make sure there are exceptions in for Roon and RAATServer (which you can read more about here).

I’d also try rebooting the Android devices and the Core if you haven’t already.

Finally, I’d make sure that your remotes are on the same subnet as your Core. If any of these devices are connected to a guest network or have a different IP range than the Core, that will cause problems with the connection.