Roon restore on different machine


Supporting a friend (via Teamviewer). Looking for steps to take please for restoring a Roon backup from a different machine.

The PSU on his machine (running Core) packed up (> not worth replacing). I moved the SSD from the old machine (Windows 10 Pro, Roon Core etc) to a similar machine and changed relevant Windows 10 stuff. Windows validation etc all fine.

In the meantime (whilst Windows 10 machine down) friend used a Mac Laptop and installed Roon Core on that. No restore from old Roon backup, he simply logged in using his existing Roon credentials and used his Tidal library (i.e. no reference to his local music while using the Mac).

Today, at his place, ran Roon and instead of logging in or creating a new Core did a ‘Restore from backup’. That seemed to go well - gradually incrementing to 100% and then message saying successful restore. However nothing seen - simply presented to the screen allowing login or create new Core. The ‘Restore from Backup’ now not seen (via Teamviewer). Machine is now headless and I’m 100 miles away.

So what can I do to get my friend back up and listening to tunes please?

Previously @support (Rebeka) in a similar plea from me at this link said the following:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder.

Assuming the above is still valid can I then login with the user’s existing Roon credentials and then from Settings > Backups > Find Backups and restore from there? Really don 't want to have Roon recreate the Library (as import dates will all be current).

At what point does the user’s other instance of Roon (on his Mac Laptop) get switched off? I want to avoid possibly mucking around for days trying to get things going and he not having any music. Or perhaps Roon will allow a temporary (say 4 days) double login?



I have been experiencing a similar problem.

The following workaround did the job for me, after uninstalling Roon completely, re-install and restore the backup again.

Hope this will help you


Hi Dirk

Many thanks for your fast response. Yes that looks like the most likely route to follow. The user has many backups available so if the one I tried to restore I can probably go back one until it is fixed.

I’ve tagged support on this thread so will wait for them to confirm (and possibly allow a temporary double Roon login) before I go in and try do things.

What was your situation that required a restore?

On my Roon I’ve been running things for about 4 years and never had an issue (other than -having to re-sign into Tidal a few times).


I tried to setup a second instance of Roon on a Windows 10 Pro computer.
My main Roon server is based on Audiolinux.

When I installed Roon on Win10, I performed a succesfull restore.
I could start Roon on Win10 de-authorizing my Audiolinux server, but then I got a continuous black screen. In Task Manager, I could see a lot of Roon activity for about a 3-4 minutes, and than almost nothing. All the time black screen.
The only thing to do was to kill the Roon process in Task Manager.

I opened a case at support, who looked a my logfiles, and made the recommendation, referred above.
Uninstalled completely (I used Ccleaner to remove all traces of Roon), re-installing, and restoring backup .
Then deleting the LOCK file, and everything worked fine.

I have (on request of support) executed different tests. I believe I have (re-started) 4 times in total.
Result was always the same: I needed to delete the LOCK file, but when I did it always worked.


Thanks again Dirk

I’m in Europe so near the end of the day. I’ll look again in the morning and perhaps support may have said something. But you are correct the LOCK seems to be the issue probably.