Roon Rock and Airport Express Wifi

Dear support,

I just bought an NUC (i5 8gb RAM and 128gb SSD) and installed Rock through the USB. That worked fine. I now get an IP adress with the warning my router is not given DHCP address.

The set is a s follows. My incoming router is wired connected to an Airport Extreme. This Airport Extreme creates a wirelless network that is picked up by an AirportExpress (AE) in my living room. The AE is wired connected to a switch that also wired connects my NUC, the NAS and Streamer.

What do I need to change to have the DHCP passed through? Where do I need to make that change: the Airport Extreme or the AE or both?


@support can you please have a look at my question?

If no one answers your question I can check my setup when I’m at home (USA Pacific time zone). I have the exact setup that you do and it works fine. It’s something in your Airport Express where you setup a bridged network assuming your Airport Extreme is dishing out DHCP addresses…

I run this so I use the Ethernet port on my Airport Express which feeds my DAC

oh that would be wonderful … please let me know the exact setting in the AE that I need to change

my AE is current set as “connect to existing Wifi” whereas there is also a setting “extend network”. Did you choose the latter ? @support


I don’t use any Airport equipment but if I understood your post correctly you have a switch with your NUC, NAS and Streamer connected to it using Ethernet cables. I’m assuming the NAS and Streamer are working and have ip addresses which they got from DHCP.

If my assumptions are correct it seems to me that the problem is with the NUC’s connection to the switch. Do the lights on the switch port for the NUC look the same as the lights on the ports for the NAS and Streamer?

Have you tried another switch port for the NUC? Have you tried another Ethernet cable for the NUC?


you are correct Tim … the NUC is connected via wired UTP cable to the same switch that connects NAS, Streamer and tv box. There is also a wired connection from the Airport Express to the switch. I did change cable positions a few times. I do believe the issue is with the AE. It “receives” its internet signal over Wifi from an Airport Extreme that is in another place in my house where the Internet cable comes in. I did change the settings on the Airport Extreme and this seemed to get the NUC receiving a proper IP address but it caused all other devices to mal-function. I turned back all settings to its original. The message I see in the NUC is that it says “addresses like http://169.254.x.x may not be accessible and are a result of your router not giving DHCP Address to this device”

Hopefully Mark will be able to help you.

Odd that the AE can give an address to the NUC or to your other equipment but not to all of them at the same time.

Good Luck … Tim

Have you tried putting your AirPort Extreme on bridge mode and your AE on Extend Network?

1 Like

currently trying that @Julio … I am interested in the screenshots of @Mark_Allen so that i can exactly see how things are set up

One other thing that tripped me up (bad eyesight I suppose) was on the Airport Express and or the Airport Extremes there are two ethernet ports. I had them backwards.

I don’t understand @Mark_Allen: the Airport Extreme and AE are connected through wifi; not wired

No worries. Just an observation that I had done in the past

I think I have it working … by setting the AE to “extend” instead of “connect”, it works … now building op Library
thread closed

1 Like

excellent. I just got home and yep “extend” is what I have. Enjoy. My Apple Extreme/Express has been flawless for at least 3 years.

that was indeed the “trick” @Mark_Allen. Thanks for the hint; Roon Rock works flawlessly now

1 Like

Enjoy Roon with your streamer

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.