ROON ROCK Audio Distortion

Hey @support,

I have 4 devices… playing from ROCK… all sound distorted.

My gear is:
IFI iNANO DAC… Upscaled to DSD 256
DENON X4500H… Airplay
APPLE 4K TV… Airplay
NVidia Shield… Chromcast

Really can’t figure it out… some setting somewhere in the ROCK?

Also when I play MQA!
Help me out?


I’ve updated your post to flag support, in meantime…

What hardware is ROCK running on and how are all the devices connected?

Also does this happen with both local files and Tidal streaming?

ROCK run through USB to IFI DAC> AMP
ROCK via ethernet to the other devices
Mayby another install of the software on the ROCK…cant figure out
Happend to all files i have…DSD up to 256…TIDAL too.with/without MQA…have disabled the setting…force max volume… doesn’t help…change the cables to the amp too…nothing changed
I listened to music all my life…it really depends how good it sounds…soe…
I’m ready to get another another DAC…but…its happened to all my devices
Any thoughts?

Go into DSP settings and enable the clipping indicator.

CLIPPING indicator… where in the OS?

I am not at home so can’t give step by step instructions.

Thatts alright…

When your home… that’s fine

Hello @Morten_Valbjorn,

Can you please try to enable “Headroom Management” in your DSP settings for one of the zones that is displaying this behavior? I would start with -3dB and if the clipping still occurs to increase that number to -4 or -5.

Please let me know if that helps.


Ok…changed the DB settings to -6
Indicator doesn’t show any clipping in playback

I really want the audio clean… looking on another DAC…But…looks strange course it is on all my devices with different playback settings

Any other solutions…let me now


Hello @Morten_Valbjorn,

I want to confirm a few things

  1. The distortion is happening for all playback zones in Roon, even zones with no DSP enabled?

  2. The distortion is happening for all formats and sample rates? For example, playback is distorted for 16/44.1, 24/96, as well as DSD upsampled streams?

  3. Did you make any other changes to your system before this behavior started?

In addition, it would be helpful if you could attempt to run the Roon Core on a different computer than your ROCK device.

  1. On another PC or Mac in your house, go to Settings > General and disconnect from the ROCK core, and then choose to run the Roon Core on your PC or Mac.
  2. Roon will ask if it’s okay to de-authorize ROCK which is okay, it will just ask you to de-authorize the PC when you return to ROCK.
  3. Import a folder with only a few test files in it to speed up the process.
  4. Attempt playback to the other zones on the network.

Let me know how your testing goes, we will continue to investigate the cause of the issue on our end.


John…thnks for answer
Ok, I’ll try to run the core on my Pc instead…write back when done testing

Ok… that was a succes… sounded just as intended … thanks.

Thanks again from Dk