Roon ROCK no longer connects to NAS music folder after 2.0 (build 1234) update

Roon Core Machine

Intel NUC running ROCK 2.0

Networking Gear & Setup Details

Orbi mesh network
Wired connection to NUC and NAS

Connected Audio Devices

Oppo UDP-205 via USB connected to Intel NUC running ROCK
Windows 10 PC

Number of Tracks in Library

Before I lost connection to my NAS, I think there were almost 6,000 tracks. Around 600 albums.

Description of Issue

After updating Roon and ROCK software to version 2.0, Roon lost the connection to my NAS where my music files and Roon backups are located. I can connect to my NAS without a problem with my computer, so there appears to be no problem with my NAS.

Roon now displays only the albums I had added from Qobuz. I cannot reconnect to my NAS at all.

Roon can’t find the NAS. Can a computer or laptop access the shares?

You may try rebooting core, NAS, and router.

To be more specific, this occurred after the 2.0 (build 1234) update. Last night, I installed the 2.0 (build 1244) update and I still have the problem. I restarted all components and still no success.

I cannot connect to any other folders, not just my music folder.

And have you tried reconnecting to the NAS in Roon? Either by editing the existing path, or setting up a new path…

Yes, I have tried but Roon does not see my NAS on the network. I tried connecting to a different shared folder on the NAS and that doesn’t work either. It just doesn’t see the NAS anymore.

Error message:
There was an Unexpected error: Invalid Network Path

As @Martin_Webster suggested, can your Windows 10 PC connect to the NAS? Can you post a screenshot of what is displayed in Windows File Explorer with \\Network\ entered into the address field?


I can access the music files from the mapped drive (m:) to the shared Music folder on the NAS:

2023-04-09 Music Folder 2 Capture
This is what I was using with Roon for several years.

In trying to resolve this issue, I created this share (\NAS_01\music):
2023-04-09 Music Share 1 Capture
I can access the files using it as well:

When I try to add either folder to Roon, it can’t find/connect/recognize the folder or network connection.

Thanks for your help with this.

It’s interesting that the NAS doesn’t show up in the \\network\ screen of File Explorer. I would have thought that it would.

It seems to have an address of What is the address of your ROCK/NUC?

The NAS did intermittently show up in the \network\ screen this morning, but I didn’t see it before. It was unusual behavior. I don’t remember noticing it there before. I rebooted my PC and it hasn’t shown up since. Plus it was only visible on the left side. I didn’t include the following screen capture because it was not consistent with normal behavior:

This morning when I saw NAS_01 in the Network list, I tried again to add it to the folder list, but Roon still couldn’t connect to it.

Use the Ip address to connect to the NAS not NAS_01

I already tried that. Same result.

I tried it again.

I added the share name.

Then I changed to ‘smb //’ and added username and password:


I’m afraid that I will have to organize my library from scratch now, or can I restore it from a previous backup when it was ‘NAS_01’?

(By the way, I thought I had already tried this combination but had no success.)

As I suspected, my tags are now empty.

Is there a way to edit the paths stored for each item? I need to change the root path from '\NAS_01" to "\".

Hey @Allan_Watson,

Ben with the support team here, thanks for your patience while our team continues to work through each thread!

Following up on your issue, it’s odd that Roon didn’t recognize the files you added, regardless if it’s in a new subdirectory. It looks to be under the same location overall, so it should recognize your files.

You are on the right path with restoring a recent back up in this case. That said, it will most likely re-route your network path to its original path, which may bring you back to the initial issue. You’d have to re-update the new path you’ve created again.

With that, I would also make sure to disable your previous shared path before adding the new path.

Let me know if you’re able to get things restored and running properly after the above. :+1:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.