Roon ROCK not appearing in Network on Windows 10


Built and got my NUC up and connected to my router. Using the IP address I can login to the web interface with ROCK without issue. My router shows that the ROCK is connected via ethernet (as it is).

For some reason it’s not showing up at all in Explorer under Network at all. My Windows 10 64bit PC is connected directly via ethernet to the same router. I’ve disabled Bitdefender and Windows Defender and no luck.

Tried changing Network and Sharing Center settings multiple times with no luck. All other devices are showing up in Windows under Network, including Sonos, DirecTV media server, Roku, printer, etc.

Went into my router and manually assigned the IP to the ROCK and did the same in the ROCK’s web GUI. Still nothing.

Really at a loss as to what to do now. This has been 4 hours of frustration.

1 Like

If you launch Roon on your Windows 10 machine, are you able to connect to your ROCK Core and log in?

1 Like

Maybe the smb1 share is not being seen…I think there was a work around for this somewhere iirc

Hey Mike, thanks so much for the quick response.

Using the Windows Roon app as a remote control app, I’m able to access the ROCK. It appears I just can’t see the smb share.

That appears to be the case. I’m able to connect to the ROCK using the Roon Windows app on the same PC that can’t see the ROCK under Network.

@wizardofoz @mike @support

GOOD NEWS! I figured it out. Posting the solution here as I’d be shocked if this didn’t come up again multiple times in the future with new ROCK builders using Windows 10:

In the Fall Creators Update for Windows 10, Microsoft disabled SMBv1 by default as they consider it insecure. This is how the ROCK exposes itself on the network, so SMBv1 is needed.

It’s very simple to enable again. Scroll down to the third post here (second reply):


Yes, I had this issue on one of my PCs a couple of months back. I just enabled the SMBv1 client function, as I think the server function is not necessary, and might be where the security issue would reside.

Roon 451


That’s good thinking. I enabled everything under the SMB 1.0 but went back and disabled the server again after reading this.

Thanks for letting us know @Sasquatchimo!

I really think it would be much better if Roon started to support SMBv2 or up.
It would make it much more straightforward to use - in my case - the Nucleus plus out of the box with Windows 10 (update 1903).
Plus, all those questions and assumptions about whether or not SMBv1 is safe or unsafe, whether as a Client or Server, would go away.
Usability (user friendliness) should be the top concern.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.