Roon Rock (NUC) Can't be Found By Roon Remote

Roon Core Machine

Intel NUC 10 Performance NUC10I5FNHN
I5, 8GB MEM, M.2 SSD FOR OS (Samsung), 2.5" SSD for Music Storage

Networking Gear & Setup Details

Modem - TG1602AMTA (Spectrum Provided)
Router - SAC2V2S (Spectrum provided)
Switch - Cisco SG300 28 port L2
Additional 5 port unmanaged TP Link 5 port gigabit switches at some locations in home
CAT6 Wired Home

Connected Audio Devices

BlueSound Node N130 wired over ethernet
Bluesound Powernode wired over ethernet
2 X Apple TV 4K wired over ethernet
Bluesound Pulse Plus Soundbar wired over ethernet

Number of Tracks in Library

Approx 5K tracks

Description of Issue

After working flawlessly for months since building my NUC Rock server back in December, it’s suddenly unable to be found on any of my Roon Remote devices (iphone 11 pro and ipad Air, an windows PC’s)

I can still find the Rock on my routers (uses DHCP) devices using the IP and I can still ping it through my PC or directly through the Cisco switch. However, it cannot be found by the remotes. I am also noticing that the Roon Server software, as displayed on the PC when I type in the IP address and reach the dashboard shows that the Roon Server Software has only been running for a few seconds. If I refresh the browser it appears that the most the Server software is running is 17 seconds max, before restarting, unprovoked.

I’ve tried reinstalling the OS, rebooting the Rock, rebooting the switch/router/modem chain including a full power cycle of each, manually restarting the server software multiple times, changing the location of the Rock to bypass the switch and run direct from the router’s ethernet port… all to no avail. My last log in Rock/DATA shows 3/29 and now it’s the 10th of April so it hasn’t been logging, apparently, but I also haven’t been using it as I’ve been out of country and discovered these issues upon returning home. No other network issues to report with numerous automation devices, etc. which would warn me if there was an outage, or major change, even when overseas.

Please help if at all possible.

Try reinstall

Either corrupted files or defect M.2 SSD

I did try that earlier, but it didn’t correct the issue. It shows it as stable version.

Try entering


and rename the folder: orbit_v3.db to orbit_v3.backup
Restart NUC.

If this does not work, rename the folder back again.
You can also check:

1 Like

Hey, that actually worked! So, what did changing from the folder titled orbit_v3.db to orbit_v3.backup actually do? I do see that the system then created a new orbit_v3.db folder once I changed it the original to a .backup. Somehow it found the core and is working now. Thank you!

1 Like

Most likely corrupted database. v3 is the latest, it generated database v3 again. If everything works, all good - just remembered reading about this orbit_v3.db being problematic for some so thought it would be worth a try :slight_smile:

Server continuously restarting is usually one of the following things:

  • Corrupt Roon (reinstall fixes it)
  • Corrupted database (restore backup or do the trick I suggested - of course, it is a challenge restoring when Roon Server restarts every 17 second)
  • Corrupt M.2 SSD (you need to replace the M.2 SSD, and reinstall)

orbit_v3.db is an error tracking database (ironic), not the main Roon database. There were some cases of corruption that caused constant crashes. It’s been fixed supposedly, but it it got corrupted before the fix, it could still cause crashes. By moving it away, a new empty version is created and the problems seems to go away.


Definitely ironic! Well, glad I was able to resolve it quickly. I was really worried all my network settings needed to be cleared and re-established. It’s working great this morning. Considering I listen to music all day while I work it’s critical that I have Roon available for my workday. Thanks all for the help in resolving this!


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.