Roon Rock on Intel NUC not seeing Qnap DAS

Roon Core Machine

Roon Rock on Topton NUC with Intel 11th Core i7 with 32GB ram
Qnap TR-002 DAS running hardware RAID1
USB-C on DAS connect to USB-A on NUC

Networking Gear & Setup Details

Network is running fine.

Connected Audio Devices

Audio devices running fine.

Number of Tracks in Library

More than 12,000 tracks consist of FLAC & DSD.

Description of Issue

Original the Roon Rock NUC was connected to a Orico DAS running RAID1 (USB-A to USB-B).
It has been running great until the 10+ year old WD Green 1TB HDD started to fail.

I decided to change the whole DAS setup to TR-002 running with WD Red Plus 4TB x2.
HDD formatted to exFAT but after I transferred all songs to the Qnap DAS, Roon Rock can’t see the Qnap DAS.

Based on a support topic of another Qnap TR-002 user facing similar issue of not able to see the Qnap DAS, his solution was to re-setup the DAS and it works for him.

I tried the re-setup route and I copied 1 album to test it out. It works.
Roon Rock can see the Qnap DAS. I can map the album and play music.

Then I proceed to copy all my music albums and now it can’t see the Qnap DAS.
I tried all available USB port on the NUC and none works.
I hook-up a Transcend external HDD and Roon Rock can see it with no issue.

I’m not sure what is the problem. Can anyone help?

Hey @Kenneth_Teng,

Thanks for your patience while we work through each thread!

Following up here, can you please reproduce the issue, and share the specific date and time in which the issue occurs? From there, we’ll be able to narrow things down to see what the issue may be. :+1:

Hi Benjamin,

Issue finally resolved after my 3rd try of re-setup and re-formatting the Qnap TR-002 DAS.

I first setup the newly purchased Qnap TR-002 on 2/25.
My 2nd tried was 3/4, which I re-setup and reformat TR-002. It works initially with only 1x music album in TR-002. Roon Core failed to see TR-002 after I copied my whole music library into TR-002.

After posting my issue on Roon Support and Roon FB Group, hence the above respond from Roon Support, I decided to give it a 3rd try.

I re-setup and re-formatted TR-002, with GPT partition and exFat format.
I first copy 1x album and Roon Core can see and add music folder for TR-002.
I then copied 10+ folders with 20+ albums and Roon Core can still see the music folders in TR-002.
I tried again with numerous folders with 200+ albums and it still works. This time my Windows laptop detect error in TR-002 and manage to scan and repair the HDD in TR-002.
With a leap of faith, I copied my whole 12,000+ songs overnight and Roon Core can still detect TR-002 and add the music folders.

There’s one time when I shutdown my Music setup and turn it back on a few hours later, Roon Core can’t see TR-002. It gave me a scared but once I reboot Roon Core, it can detect TR-002 again.

I have now turn on and off my music setup a few time now with no issue for the past days.

I still think Roon Core support for Qnap TR-002 DAS is still a bit unstable and hopefully Roon support can find the root cause and provide a permanent fix to it as I’m not the only user facing the issue with TR-002.

1 Like

Hey @Kenneth_Teng,

Thanks for the update!

If you could please jot down the date and time next time you run into this issue, and share that information here it would be very helpful in regards to reviewing your core diagnostics. :pray:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.