Roon running painfully slow

Core Machine (Operating system/System info/Roon build number)
Kingdel NC860 Fanless Mini PC, Slim Desktop Computer, Intel i7-8550U 8th Gen. 4 Cores CPU, 16GB DDR4 RAM, 256GB SSD, 4K 4096x2304, HD Port, DP, WiFi, Metal Case, Windows 10 Pro

Running Roon Version 1.7 (build 555) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Asus AC1900 router
Gigabit switch
Cat 6 wire to all devices and endpoints (except tablets & phone)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Sonre micro rendue cat6 in spdif out to benchmark DAC

Description Of Issue
Main Issue - Roon is running painfully slow. Impossible to get anything done. Playback works but if I hit pause or track skip it goes silent - responds after 60-180 seconds.

I moved my core from my nas to the new kingdel machine in may (5-21 maybe) as the nas was slowing down making db work slow. At 1st the kingdel was WAY faster - I was so happy, then about 10 days ago it began to slow down. Now it is so slow I am giving up. Not happy, I need to fix this ASAP. Please help.

Yesterday I dumped 4 TB of files off my nas hoping that would speed things up - no such luck it actually seems slower.

Thank you,

Hi @David_Haaf,

Is there any On-Demand or Background Audio Analysis active? You can check this under Roon Settings -> Library. I would set both to off for the time being to see if this helps.

Please also share a screenshot of your Roon Settings -> Storage tab, let’s take a look to see how you have your directories set up.

Hi Noris,

I set the 2 sliders to off a few hours ago and roon is still running slow and it has a new intermittent problem - a long pause = silence (90-180 sec) after some songs.

Fanless mini-PC’s such as yours are only capable of operating because an Intel processor can throttle itself way down in order to prevent itself from melting to the motherboard. This thermal dissipation is the reason why Intel includes an active cooling solution with their retail CPUs that consists of an aluminium heat sink and fan.

How hot, to the touch, is your unit?

1 Like

Hi @David_Haaf,

This is a good point, it could be overheating.

Also, looks like you have quite a lot of apps open, I’d try exiting some of them in case you’re running out of resources or taxing your CPU/GPU too much. You can try with all closed except for Roon as a test to get a good baseline.

If its using Intel GFX then it could be the Intel GFX driver bug that makes the UI very sluggish. Make sure the GFX drivers are up tp date.

Unit is almost too hot to touch, but I can keep my palm on it.
All the apps running are on my laptop (not core machine).
I will go ahead a close the apps as a test. But I should mention that the slow performance is the same on my laptop, tablets, phone, and roon app on SSD in core machine.

I do not see GFX in the device manager. The display adapter is Intel UHD Graphics 620

I recommend you download and install the following:

In that software, you’ll find a specific section (“CPU”) that will report the temperature of each core of your processor.

For the latest graphics drivers, search for “UHD Graphics 620” on Intel’s web site and download the appropriate driver.

You are also streaming to 2 endpoints it seems which is also going to tax the system more.

If it’s too warm for a child’s palm then you are into a new spec cpu most likely as this one can’t Capone or has some issues…if it’s fanless it’s under powered, if it does have a fan perhaps its clogged with dust or not working at all.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.