Roon running slowly on laptop


(David Carter) #1

Very new user of Roon/Zen Mini. My set-up is as follows.

Roon Core on Zenmini MkIII.

Using Asus X550C laptop as control device. Its spec as follows:

1TB HDD; 6GB RAM; Intel i3-3217U processor; Intel® HD Graphics 4000 card-Open GL shows as 4.0; resolution set at highest possible at 1366 x 768; running Windows 10.

When I use laptop as control device and open Roon, as it builds library (from ZenMini Music folders), display of album art is very slow; this also makes all the Roon system control options (e.g. Storage; Settings) very sluggish to respond.

When I use other devices as Control (e.g. Samsung Tablet, Android devices) response is instant and library builds really quickly.

Any ideas/suggestions for improving Roon’s speed on the laptop. OK, it’s a few years old, but even so…


(Ged) #2

Try going to Settings, Setup and increasing the cache size.


#3

I remember i saw this tip in the past: If you’re using the 64-bit version try the 32-bit version of Roon instead.


(David Carter) #4

Hi Ged. Quick response there thanks.

Do you mean cache size on Roon / Settings / Set Up? Or on the laptop?

When I look at Roon Setup, the album art is set at 512 MB. Have already tried increasing that to the max allowed, but response was no better.

Cache field in Roon only offers me option to Clear Cache


(David Carter) #5

Thanks for a quick reply BlackJack.

Not sure I remember seeing an option when I downloaded Roon onto the laptop to select a 32-bit version rather than a 64-bit version. Is that your experience?

Understand the distinction you’re making here. Laptop is 64-bit.


#6

You have to download the 32-bit version, it’s not an install option.


Direct download link here.


(Ged) #7

The 32 bit version is a good idea. And yes, the cache size on the laptop as each client setting is individual.


(David Carter) #8

Thanks that is really helpful


#9

Means “it’s better with the 32-bit version” or “thank you for the link I will try it later”?


(David Carter) #10

Thanks for the Link will try a bit later, will let you know how I get on


#11

Your processor is certainly not a cheetah but surely not a snail.

So additionally: Might it be that you have installed any additional antivirus software?
If so, please make sure that the built-in one is disabled because having more than one active at the same time can severely decrease the performance of your system.


(David Carter) #12

Wow! Your knowledge is impressive. Thank you so much.

Have just loaded the 32-bit version instead of the 64-bit version, and things now working very speedily indeed on my laptop. Problem solved.

Really appreciate your help there.


#14

I’m glad it worked. As the problem is solved now, feel free to mark the post that contains the solution.


(Mr Fix It ) #15

The issue FYI is the intel graphic drivers that don’t play nice with roon…been noted many times before


(system) closed #16

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.