Roon rushes "wildly" through tracklist without telling why

On A samsung ativ 9+ running latest Roon (client), Roon rushes through the playlist or the album tracks, but regrettably, unable to play the tracks.

The major question: Why does this not cause any notification to user? Are we expected to guess what is going on? I have done that, and here is the answer:

The error message should have been “Roon is unable to access the defined audio output line because Roon requires exclusive mode, however this audio device is defined to run in non-exclusive mode”.

It could be suspected that Roon in later version mandatorily requires “exclusive mode”, and that this is the reason, since other mediaplayers on the same device is working like normal?

Is there a reason why roon should not or will not play unless exclusive operation is possible? If so, why? What I want as a user, is the option to decide which mode to use. If I recall correctly, this used to be a toggle option, not?

More on the lack of error notifications:
When thinks are not working, I have the expectation that a modern peace of software should ALWAYS explain what went awry, with possible reasons, possible remedies, and so forth.

Roon lacks the feature to discover that audio output is unavailable and therefore, tries another track, then another track, then another track. It means, sorry, that Roon show signs of being immature.

This error was also reported 3 years ago, so therefore it is suggested to the Roon team that you sit down and collect this type of erros in¨to an “issues” list and get the job done to fix things.,aac

Hi Carl-Henrick,

What version of Windows are you running ? The symptoms you describe can occur if an OS is lacking codecs for relevant files. Windows N, K and KN lack media features including codecs for various reasons. There is a link to download the media pack in the linked article. It may well be that you have the European Windows N. This KB page may also help.

My guess is codecs are missing, but I can’t tell without more information. There is an orange popup that explains what went wrong when it skipped.

Your guesses are pretty far off reality. Roon does not require exclusive mode unless you set it that way.

Are you running the Realtek audio drivers on the laptop?

Thanks for trying to help. My responses so far:

@andybob : Latest Windows 10 Pro. Samsung ativ 9+ i5. As I am using this pc for audio programming etc, I am pretty sure the pc is not the problem.

@Rugby: Yes. I believe the realtek drivers are now an integral part of the Win10 setup? The realtek drivers are by far the largest available audiodriver for a Windos system with its 100mb size, but it gives me no problems with other mediaplayers, nor with Reaper, the DAW I use for music production.

@danny: I believe you and thus, I am far off, but I would like to mention that on my macbook pro (i5), there is still an option to require exclusive mode, but not on my Windows Ativ (also i5). And there is no orange warning explaining what went wrong. I do see a change however, in that the rushing through tracks now takes place at lightening speed, while it used to spend a second or so on each track prior to moving to next track.

Maybe these “the next morning” observations can be helpful for Roon developers:

Yesterday, as Roon was rushing through tracks, unable to play for half an hour or so, I deliberately started a radio app that I know run in non-exclusive mode, since I wrote it myself. The radio behaved like normal, and thus we also know that no other media app on the pc was locking the selected audio output, else the radio would not be able to play. Both Roon and the Radio was set for default playback device in Windows.

Now, next morning, I restarted Roon, and now it is back to normal playing tracks. In the in between time period, I did only one thing: Sleep.

Therefore, it is logic to assume that something internally in Roon caused the problem yesterday evening. I dare another diagnosis:

  1. The audio setup module of Roon could for some reason not setup a chosen device for playback. However, neither the user nor other modules in Roon was notified. (Could the reason be that the audio device is setup with 192kHz sampling rate and that this device requires players to adapt to this?)

  2. Therefore, the playback module in Roon is under the impression that playback is currently possible, and make the wrong assumption that “it has to be something wrong with this track N, since it cannot be played, so let’s try next track N+1”, and there you go.

To get past this very old hurdle in simple playback:

A. Fix the bug that causes Roon to be unable to play on an audio outlet that other apps can indeed use at that point of time. One possibility could be to study what is done in flushing “internal cache” as Roon is restarted, and then add that flushing as an attempt to fix things (without a restart).

B. Create an intelligent error notification to the user for the factual situation that the audio device is REALLY unavaible, e.g. due to being occupied by another app in exclusive mode. Roon should suggest remedies like “Playback on this outlet currently unavailable. Please verify that no other media app is using this outlet in exclusive mode”…blabla. (Could be that this is already a feature, but I have not been in that situation lately so I would not know).

C. Make sure that the audio setup module in Roon improves on its corresponding internal notification to the Roon playback module, so that the “silly” rushing through tracks could be a game of the past. This error was there also when this roon subscription was initiated several years ago, so timing should be good to fix this.

I’ve experienced this. Not often, maybe once a week - not the end of the world. But when I saw something similar happen with Audirvana I assume it’s an occasional networking issue for me.

The most annoying thing for me is that if I have 100 items in queue in Roon, I lose all 100 items as Roon races through each track in the queue. And when it gets through all 100 items, the entire queue is lost.

Whereas with Audirvana, the 100 items in queue don’t go anywhere, even if music stops. So after the networking issue is resolved, it’s easy to restart from the last track you were playing. The entire queue list is kept.

Apologies for going a little off topic.

No, Win 10 just downloads those drivers onto your system because that is what is embedded on the main system board. In all my systems, I immediately remove those drivers as they have caused, for me, issues in other programs. I find the MS High Definition Audio drivers to be superior.

I am sure Creative Labs would disagree.

Hey Roon, I like what you did there with v1.4 :slight_smile:


Just FYI, I was finding a way to completely stop the reload of realtek drivers because it contains an idiotic solution in that you get a warning EACH TIME you inject headphones (or speakers) to the headphone jack, that high levels may harm your ears etc.

I did that by preventing write access to the realtek folder. I made a blog about it that became the most read.

However, this silly bug of the century; the most deeply annoying audio bug ever made since there is no way for Windows to guess if there is a headphone or a speaker connected, has since infected also into normal MS drivers, hence I let Realtek in again.

@danny, I was able to create some documentation on this problem. The screenshot shows that the Samsung Ativ 9+ internal speakers are running in 192kHz-24bit mode, as is the whole pc. As Exclusive mode is checked in Roon (this is a roon remote), the red error message appears.

At the same time, an internet radio is playing on that output, blended with the MediaPlayerClassic HomeCinema (a fork of that app), playing a track via wifi from the USB HDD connected to the Roon Server. Tidal is also working. Whether these other apps are active or not, is not relevant to the error. The Windows “test” runs just fine.

This is why I originally thought Roon has an issue with “exclusive mode”

It is ONLY Roon that has problems on this PC. It appears as if this Roon Remote perceives that the speaker output (and other outputs) is unattainable, but note that the error message in the given context isn’t exactly pinpointing.

A video on Roon “rushing wildly” through tracks is found here:!AgwTOVHwFIUih848SAEoJJJym5W0oA

The following did not remedy the situation:

  • Roon exclusive mode toggling
  • Roon DSPEngine/sampleRateConversion toggling.
  • Roon delete cache files
  • Restart of PC

This PC plays error free on any other output in the Roon multiroom setup, so it is related to the outputs of this PC. I can find nothing abnormal with the audio of this PC, it is working perfectly with all other mediaplayers.

@support we need logs from @Carl_Henrik_Janson to see why the tracks are being skipped.

@Carl_Henrik_Janson – we need some explicit information from you. please answer the following questions (regardless of whether you have done so in the past or if you think they are unimportant):

  • confirm that this skipping happens when you have exclusive mode turned off in Roon
  • the brand/model of your audio device, how it is connected to your Roon Core
  • the format of the audio files you are playing (pcm/dsd, bit depth, channel count, sample rate, and file format)
  • does it work if you shut down all your other players?
1 Like

Hi @Carl_Henrik_Janson ----- Just touching base with you as per Dan’s previous post.

Letting you know that I have went ahead and enabled diagnostics on your account so we can try to get a sense as to what could be causing this skipping behavior during playback.


confirm that this skipping happens when you have exclusive mode turned off in Roon

the brand/model of your audio device, how it is connected to your Roon Core
Roon Core: Samsung Ativ 9 (a 9+takedown but with i5 etc)
Roon Remote: Samsung Ativ 9+ Win10/update 1703.
Connection: wifi 2.4 (throughput measure: approx 20Mbits), or 5GHz (approx 70Mbits)

the format of the audio files you are playing (pcm/dsd, bit depth, channel count, sample rate, and file format)
In this case: CD format; wav 16b 44.1 2ch

does it work if you shut down all your other players?

I was unable to attach a fresh log due to file extension not allowed. Please advice.

@eric. OK. The skipping? Looks like it is related to what Roon thinks is an unavailable local output device (the laptop speakers). This roon remote may play (and not skip) on any other roon remote or core. So at least it is not the connection to Core that is the reason.

need to know your audio device info, not your remote/core info.

This audio device is not connected to Roon Core, since it is the built in speakers.

Note: This remote is also a Roon Core when out of the house, else not. So there are “core” db files etc on the drive.

Note: Have not tried to reinstall, since there is a logging going on.


it’s the built-in windows audio device on your remote?

yes. I hope the “remote” means any Roon client on any pc using the core.

Trying to play from core to that remote zone, the log on the core says:

Could not find that in the remote’s log.

In the remote there is a lot of loggin because Roon cannot find, or is struggling with:
12/27 18:41:30 Info: [broker/locations/directorystoragelocation] drive availabilitychanged: False, FileBrowser.Entry: \rt-ac66u-1ac0, Music : \High Resolution Music (flac wav)\Gube Music (it was False)

I just mention in case it is confusing in a log study, that this HDD was moved to the core a while ago, but that I had not fully updated the settings/storage accordingly. I did that today, but maybe the cache is saying I havent.

Also note that the second last Roon updating was working on this remote. Could be the last update that created a problem