Roon Search incomplete

Roon Core Machine

Nuc 11, i7, 16GB, 2TB SSD

Networking Gear & Setup Details

Enterprise wired

Connected Audio Devices

USB and Ethernet 1GB

Number of Tracks in Library

About 30000

Description of Issue

Roon search fails to deliver full results in some senarios.

eg 1. Search for Kiss returned 6 albums, I have 9. Elton John returns all results. Poor Kiss.
eg 2 Search for Motley Crue, returns 2 albums I have 12. Note there are 2x umlauts over letters, this may have an impact
eg 3 Queensyrche returns 0 albums… I can find 2 by typing Queen and looking thru. There is an umlaut over a letter as well. 9 Queensyrche albums.

Problem was fixed a while ago and has returned.

Also I have removed the Tidal account to help diagnose…


Please share some screenshots.

Please see attached.

Hope it worked.

Okay, this may be a regression since “ Queensrÿche” does return results.

If you’re searching for “Motley Crue”, surely the top hit should be the artist? And if you follow that link you’ll reach their discography.

Your search string is wrong. It’s ‘Queensryche’ and not ‘Queensyrche’. Catching those typos is still on Roon’s todo-list.

Using the correct search string I bet you get these results, too:

Screen Shot 2022-06-08 at 11.49.51 AM

1 Like

Good catch, @Andreas_Philipp1!

Not a regression then…

1 Like


I am not sure it’s a typo. If I type Queensyrche its the same result. Also I use Apple Music next to my local Roon library just to validate results. I have set Apple Music to use only my library as well.

I have disabled Tidal, so its local library results returned.

BTW its not just the 2 Artists examples, quite a few others as well.

Lastly typing Queen returns many artists including some Queensyrche. Typing Queens, so the single ‘s’ letter drops out all Queensyrche results but leaves the other artists and tracks in.

Thanks kindly.

Wrong again. Try typing ‘Q u e e n s r y c h e’ …

It’s ‘queens ryche’ without the space…

I am typing a contiguous word, no space.

Not that far gone yet…

Thank you.

But you invert the ‘r’ with the ‘y’… look again and you will see the error. Good luck.

Let’s forget for a moment the first part of the name ‘queens’ and focus on the second part. This is ‘ryche’ and NOT ‘yrche’ as you have put it… so the whole search term should be ‘queensryche’.

1 Like


Looks like we may have messed up and re-typed the wrong word between my iMac and Windows PC.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.