Roon Server 1.6 crashes on startup

I’m running Roon Server 1.6 (build 390) on Ubuntu 18.04.01 LTS 64bit. It was working well yesterday but this morning the server process keeps restarting. From the log file I can see that the connection to Tidal has been made successfully, an then the last two lines of the server log file are:

01/31 09:57:02 Trace: [scd] reinit
01/31 09:57:02 Trace: [scd] using subnet a8c0

Then it seems that the server is restarted and a new log file is created.

Any ideas? Obviously Roon is unusable for me at the moment.

After a little exploring I have been able to run the server by hand and get the following output. Seems like the server is trying to do something illegal.

aac_fixed decoder found, checking libavcodec version...
has mp3float: 1, aac_fixed: 0
terminate called after throwing an instance of 'OpenHome::NetworkError'

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) OpenHome.Net.ControlPoint.CpDeviceListUpnpServiceType.CpDeviceListCreateUpnpServiceType (intptr,intptr,uint,OpenHome.Net.ControlPoint.CpDeviceList/CallbackDevice,intptr,OpenHome.Net.ControlPoint.CpDeviceList/CallbackDevice,intptr) [0x00030] in <21295a8acb1a4b59920209b723ef0864>:0
  at OpenHome.Net.ControlPoint.CpDeviceListUpnpServiceType..ctor (string,string,uint,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler) [0x00042] in <21295a8acb1a4b59920209b723ef0864>:0
  at OpenHome.Net.ControlPoint.CpUpnpDeviceListFactory.CreateListServiceType (string,string,uint,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler) [0x00007] in <21295a8acb1a4b59920209b723ef0864>:0
  at Sooloos.Broker.Transport.SongcastDirect.ReInit () [0x00235] in <dcbcf4f91fec401e800a83ba373c6044>:0
  at Sooloos.Broker.Transport.SongcastDirect..ctor (Sooloos.Broker.State,Sooloos.Broker.Transport.Module) [0x0007e] in <dcbcf4f91fec401e800a83ba373c6044>:0
Cannot transition thread 0x7f9658144700 from STATE_BLOCKING with DO_BLOCKING

Hi @AndrewW,

Please accept our apologies for the difficulties here.

I’d like to get a copy of your logs so I can pass them along to our technical team for analysis. May I ask that you please follow the instructions found here to find the logs for your Core machine. Once you’ve located them please zip them and share them here via a shared Dropbox link. If you don’t have access to Dropbox or another file sharing service just let me know and I can PM you additional instructions.

I don’t have a dropbox account. Please provide an email address where I can send them to. The ZIP file is only 135kb.

@AndrewW — PM sent

Thanks - I have uploaded the logs. Here is a list of the software that has been installed or updated since the last time Roon Server was working:

2019-01-30 19:12:43 upgrade tar:amd64 1.29b-2 1.29b-2ubuntu0.1
2019-01-30 19:12:43 upgrade libasound2:amd64 1.1.3-5ubuntu0.1 1.1.3-5ubuntu0.2
2019-01-30 19:12:43 upgrade libasound2-data:all 1.1.3-5ubuntu0.1 1.1.3-5ubuntu0.2
2019-01-30 19:12:43 upgrade linux-signed-generic:amd64
2019-01-30 19:13:36 install linux-modules-4.15.0-44-generic:amd64 <none> 4.15.0-44.47
2019-01-30 19:13:38 install linux-image-4.15.0-44-generic:amd64 <none> 4.15.0-44.47
2019-01-30 19:13:38 install linux-modules-extra-4.15.0-44-generic:amd64 <none> 4.15.0-44.47
2019-01-30 19:13:42 upgrade linux-generic:amd64
2019-01-30 19:13:42 upgrade linux-image-generic:amd64
2019-01-30 19:13:42 install linux-headers-4.15.0-44:all <none> 4.15.0-44.47
2019-01-30 19:13:46 install linux-headers-4.15.0-44-generic:amd64 <none> 4.15.0-44.47
2019-01-30 19:13:48 upgrade linux-headers-generic:amd64
2019-01-30 20:36:58 upgrade update-notifier-common:all
2019-01-31 13:09:04 install unzip:amd64 <none> 6.0-21ubuntu1
2019-01-31 13:09:04 install zip:amd64 <none> 3.0-11build1

Hi @AndrewW,

I passed the logs along to the team and they found an issue that points to your device being in a bad state. Can you try giving the Core machine a reboot and let me know if you’re still experiencing this same behavior?

Hi @dylan

Can you expand more on what you mean re: “a bad state”. Everything else running on the machine is just fine :slight_smile: I used to be a Unix sysadmin and so feel qualified to know when things are looking rough…

I have rebooted the machine several times and Roon is still not working, so the problem is still there.
I’d suggest that there is some issue with mono, and the code that you have for Roon Server.

I have given you the stack trace which shows exactly where Roon Server is crashing - software should not crash - at the very least it should report an error and exit nicely :slight_smile:

I have just re-run the server without the two environment variables set (ROON_DATAROOT and ROON_ID_DIR) and the server started fine. I was able to connect to it with a MacOS client. This was without a reboot :slight_smile:

So there is something about the config that I have which is causing the crash. I have the music stored on a CIFS file system (served by a Synology AFP file server), and I connect to TIDAL. I also have a number of IP Radio streams defined.

As it has taken about 6 hours to get the suggestion that I reboot my machine I am now at the stage that I will do more debugging of this problem myself. I am starting to wonder why I spent the money for a lifetime subscription…

There is clearly something wrong with the server code. This is totally reproduceable for me:

  1. remove the directories from /var/roon so that the server starts ‘fresh’
    rm -rf RAATServer RoonGoer RoonServer

  2. start the server again using I get the following output:
    00:00:00.001 Trace: [childprocess] using unix child process
    aac_fixed decoder found, checking libavcodec version…
    has mp3float: 1, aac_fixed: 1

  3. Start a Roon client on MacOS and connect to the server. Then put my Roon login details. The sever immediately crashes:
    terminate called after throwing an instance of ‘OpenHome::NetworkError’

    at <0xffffffff>
    at (wrapper managed-to-native) OpenHome.Net.ControlPoint.CpDeviceListUpnpServiceType.CpDeviceListCreateUpnpServiceType (intptr,intptr,uint,OpenHome.Net.ControlPoint.CpDeviceList/CallbackDevice,intptr,OpenHome.Net.ControlPoint.CpDeviceList/CallbackDevice,intptr) [0x00030] in <21295a8acb1a4b59920209b723ef0864>:0
    at OpenHome.Net.ControlPoint.CpDeviceListUpnpServiceType…ctor (string,string,uint,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler) [0x00042] in <21295a8acb1a4b59920209b723ef0864>:0
    at OpenHome.Net.ControlPoint.CpUpnpDeviceListFactory.CreateListServiceType (string,string,uint,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler,OpenHome.Net.ControlPoint.CpDeviceList/ChangeHandler) [0x00007] in <21295a8acb1a4b59920209b723ef0864>:0
    at Sooloos.Broker.Transport.SongcastDirect.ReInit () [0x00235] in :0
    at Sooloos.Broker.Transport.SongcastDirect…ctor (Sooloos.Broker.State,Sooloos.Broker.Transport.Module) [0x0007e] in :0
    at Sooloos.Broker.Transport.Module.Enable () [0x001e9] in :0
    at Sooloos.Broker.Transport.Module.UpdateEnabled () [0x00035] in :0
    at Sooloos.Broker.Transport.Module.b__74_0 (Sooloos.Broker.Api.LoadStatus) [0x00001] in :0
    at Sooloos.Broker.LoadStatus.b__35_0 (System.Action1<Sooloos.Broker.Api.LoadStatus>) [0x00002] in <dcbcf4f91fec401e800a83ba373c6044>:0 at Sooloos.Concurrency.EventHandler1<HANDLER_REF>.Dispatch (object) [0x0000c] in <1eb920acb5f1437b9b7b6a9895d6076f>:0
    at Sooloos.Concurrency.EventHandlers.Dispatch (System.Collections.Generic.List1<Sooloos.Concurrency.FiredEvent>) [0x0003b] in <1eb920acb5f1437b9b7b6a9895d6076f>:0 at Sooloos.Concurrency.SharedState1<THREAD_REF>.FlushEvents () [0x00034] in <1eb920acb5f1437b9b7b6a9895d6076f>:0
    at Sooloos.Broker.State/<>c.<_InitTransportThreadSync>b__147_0 () [0x0001f] in :0
    at Sooloos.SynchronizationContextThread.OnBeforeEntry () [0x0000b] in <7f0a74b68d2a4a0ba3084b62b8028591>:0
    at Sooloos.SynchronizationContextThread.Dispatch (Sooloos.SynchronizationContextThread/SendOrPostWrapper&) [0x00007] in <7f0a74b68d2a4a0ba3084b62b8028591>:0
    at Sooloos.SynchronizationContextThread.Go () [0x00025] in <7f0a74b68d2a4a0ba3084b62b8028591>:0
    at System.Threading.ThreadHelper.ThreadStart_Context (object) [0x0001f] in <370a0c27f4b74d1a81431037df6d75bf>:0
    at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool) [0x00073] in <370a0c27f4b74d1a81431037df6d75bf>:0
    at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool) [0x00004] in <370a0c27f4b74d1a81431037df6d75bf>:0
    at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object) [0x0002f] in <370a0c27f4b74d1a81431037df6d75bf>:0
    at System.Threading.ThreadHelper.ThreadStart () [0x00014] in <370a0c27f4b74d1a81431037df6d75bf>:0
    at (wrapper runtime-invoke) object.runtime_invoke_void__this
    (object,intptr,intptr,intptr) [0x0004f] in <370a0c27f4b74d1a81431037df6d75bf>:0

I am going to try a fresh install. I really expect more from $500 software.

I have done a fresh install of Roon. The software still crashes as soon as my user details are entered. Same error as above.

Hi @AndrewW,

Thanks for the additional information here. I’m going to discuss further with the technical team and let them know the details you’ve shared above. I’ll let you know ASAP when I have next steps from them.

I appreciate your patience here!

Looks like the problem was related to dodgy Ubuntu kernel (4.15.0-44) - released on 30-Jan-19. I reverted to my previous kernel to get Roon working, but noticed that a new version was released today. Now running 4.15.0-45 and Roon Server is working again.

So anyone running Roon Server on Ubuntu 18.04 LTS - watch out for 4.15.0-44 kernel!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @AndrewW,

I wanted to reach out and let you know that we released Roon 1.7 Build 571, which includes some improvements that we believe should help here. Please give the update a try and let us know if it helps!

You can read the full release notes here:

Roon Support