Roon Server cannot connect after update

Roon Core Machine

MacBook Pro M1 max 64GB, Sonoma14.1.1
and
AsusTek PN53, Debian 12, 16GB

Networking Gear & Setup Details

wired LAN, 1000BaseT, netgear switch

Connected Audio Devices

Meridian 218 Zone Controller, Meridian DSP5200SE

Number of Tracks in Library

using mainly qobuz and some tidal streaming

Description of Issue

I normally use the debian12 system as Roonserver, only when on holiday, I switch the license to my MacBook Pro to have the same experience while using a Questyle DAC and beyerdynamic T1 headphones.
Normally, when using Roon on Macbook, I switch to the Linux Server as Roon Core, having the option to either activate the Macbook or select another RoonCore. Since the update, Roon does not offer the local Roon Server anymore but “spins”. I still can select the remote server, on Debian12, and this one works as usual.
As it seems, now I could not activate the local server on the MacBook, anymore.
Is there a way for me to re-activate the local core on MacBook?

  1. check and confirm that your Roon Server is running in the taskbar.
    image
  2. Do you see a Select a different Roon Server link like below? If so, click it and re-connect to your server.
    2023-11-08 12_24_52-Window

There was a Roon update that separates the Roon Server in this way. Usually the switch to the new server should happen automatically, but sometimes it needs help as above.

See here for the details about this update:

SOLVED!
… at least for me, as I have two Servers available:
1.) while the macbook Server produces a “spinner” (waiting …), I could still connect to the Debian12 server. When connected, I opened settings, disconnected from Debian Server and could then select either of my both servers, means, local MacBook Pro M1max as well as Debian12 AsusTek MiniPC PN53. After this, the Roon symbol appeared in the menu bar and everthing seems to be ok now!

This worked for me! Thanks!!

1 Like