Roon Server crashing repeatedly

@support I have a Nucleus+ and was on a good run of over 40 days with no issues and now with this new update (Build 913) I am having the same issues of constant Roon Server Software crashes/restarts.
I can access the Web Interface.
I am using the standard power supply.
Nucleus+ is completely open and vented.
I am only accessing a library stored on NAS.

As a further note I am noticing that if I do any edits within my library it causes the Roon Server to crash/restart. Also noting that when the library reloads many images are not there which requires another Roon restart.

Update (mar.8) I have now counted 38 crashes…

This keeps on happening!!!

Have you tried a reinstall from the web gui page?

Hi - it is the Roon Server Software that is crashing and that cannot be reinstalled.

Everything is reinstalled with that action.

A post was split to a new topic: Every start up is a chore since 913

That did not fix the problem.

@support should get to you in the queue soon I hope

1 Like

Hi @Wayne_Carter ,

Thanks for reaching out. We pulled logs from your Nucleus and it looks like it is running out of memory, but the exact cause is not clear. I’ve looped in QA to look over your logs, we will reach out once that’s taken place, thanks!

1 Like

Hi @Wayne_Carter ,

Thanks for your patience here while we consulted with the team regarding your case. It appears that the Nucleus is running out of memory while it is doing image processing.

We tried to reproduce issues surrounding this area of image processing but we have not been able to do so. Can you please let us know:

  1. Is there anything notable about your local library image files? Do you have a large collection of TIFF files or image files with any strange format(s) or do you use particularly large file sizes?

  2. What is your current Roon Settings → Library → Import Settings → Artwork setting set to? Options for this include Prefer File, Prefer Roon, and Prefer Best.

Let us know when possible, thanks!

Hi @noris
My entire library is stored on a NAS which is ethernet connected to the same network as the Nucleus+.

  1. Most of my music files are FLAC or ALAC, the library is currently 238,237 tracks (8.6TB) and virtually all the image files are jpeg. Not really aware of any unusual formats.
  2. Current settings on Artwork is “Prefer Best”.

For what it is worth I haven’t seen this problem before the recent update. I did however have some other issues in the recent past where I was told by Roon support that the thought was they were related to memory issues.

Thanks for your help!

2 posts were merged into an existing topic: Roon repeatedly crashing

Hi @Wayne_Carter ,

Thanks for providing that information.

Yes, I recall the backup issue you had, also related to memory during database integrity checks, this is an interesting pattern and I have noted this in your case file.

Can you please confirm that the issue also occurs if you disable your Roon Settings → Storage locations? If it does then it would be helpful to have your database for testing in-house, please confirm this first and then use these instructions to upload the database to the folder below and let us know once complete, thank you!

@noris Hi - my NAS library is the only thing I have going through Roon so when I disable there is nothing in the dashboard other than the message to go to the Settings and make sure everything is connected.
I have uploaded the zip file as requested.
Thanks very much for your help!

1 Like

Thanks for sending this over @Wayne_Carter , I’ve forwarded this on to QA.

@Wayne_Carter, we have a theory as to what is going on here and would like you to try something if you are willing. This won’t impact your library in any way or otherwise make a bad situation worse.

  1. Go to the Nucleus admin webpage and stop RoonServer
  2. Connect to the database storage on your Nucleus by connecting to \\NUCLEUS\Data (windows) or smb://NUCLEUS/Data (mac)
  3. Navigate to RoonServer -> Database -> Orbit
  4. In that folder you will find three subfolders. Delete the one named orbit_v3.db
  5. Start RoonServer back up via the admin webpage

This will reset an internal housekeeping system which may be misbehaving.

Please try the above and let us know if it makes an improvement.

1 Like

Hi @AMP -
I did as you suggested and then tried going in and out of my library a few times to do some edits and after about 5 edits the Roon Server crashed again.
I will keep trying throughout the weekend and see if this continues.

1 Like

Thank you @Wayne_Carter. Please keep us posted on what happened. We should have some results from our analysis of your database early next week.

Hi - Just following up. I haven’t been seeing this happening for a few days now - Nucleus Server is at 6 days - 5 hours without crashing and I have been doing edits.
Not sure if you guys did something but if so - thank you!
I will weigh back in should it crash again…


The behavior will come and go and that’s the nature of the bug. Fix will be out early next week.

Thanks for your continued patience on this!

1 Like

This topic was automatically closed after 45 days. New replies are no longer allowed.