Roon Server does not recognize Mytek Stereo 192 Firewire while OS see the Mytek

Roon Server Machine

MacMini 6,2
MacOS 12.7.2
2,6 GHz Quad Core i7 / 16GB RAM

Networking Gear & Setup Details

FritzBox 7530 AX / WiFi

Connected Audio Devices

Mytek Stereo 192 DSD via Firewire

Number of Tracks in Library

ca. 10000 Tracks

Description of Issue

Everytime I turn the Mytek on, Roon Server cannot recognize it.
I’m forced to restart Roon Server.
The OS has no problems to see the Mytek, it is only Roon Server…

Add images


Hi @Steffen_Meier,
Thank you for your patience while we worked through the queue. Please provide a screenshot of the audio settings in Roon and we will be able to troubleshoot further.

Hello Daniel,
thank you for getting back to me.
I tried different settings for the Mytek Device (exclusiv Mode on/off etc.)
but the behavior doesn’t change.
It was flawless untill one roon update in late 2023.
Best Regards. Steffen

01_Server running_than Mytek turned on

02_after Server restart

03_Mytek Settings

Hi @Steffen_Meier,
Thanks for the screenshots. Try opening the terminal and typing sudo killall coreuadiod this will restart your CoreAudio. That should hopefully fix the issue.

Hi Daniel,
unfortunately your suggestion did NOT fix the issue.

Oh no, I was afraid that might be the case. Unfortunately your Mytek is not a UAC2 compliant device, Mytek built their drivers, and they haven’t been updated in nearly half a decade. Apple has obsoleted this protocol. We will do what we can to help but please be aware there is a strong possibility this will not work.

Your RoonServer can see the device, so we’ll need to see a video or a timestamp of this behavior to pin down the event in logs. In the meantime, you can try to uninstall and reinstall the Mytek Mac driver from their website. You can also try to use a different USB port. Make sure you are using the machine’s actual powered USB bus and not some external USB dock, if you haven’t checked that already.

Thank you for your continued patience with this process.

Hi Daniel, thank you again for your suggestions.
I know that the Mytek is not USB class compliant -
thats why I use it only with Firewire.
The device has no USB connection and a USB Driver is not installed.
(Myteks USB-Driver does not support MacOS since El Capitan)
My impression is, that after powering the Mytek on, it will take some time (15 Minutes) until the server (sometimes) recognize it.
It seems that the Firewire Port and/or Core Audio + a connected Firewire Device is not overseen by roon server?
For a workaround - is ist possible to relocate Roon Server into the first level of the application folder without doing any harm to the system? Then I could use Apple Shortcuts to initiate a server restart with a one button action on my iPhone.
Best Regards.
Steffen

You can give this a try, the Roon database is located in ~Library, so it may work. Keep in mind though that you are tinkering, we have not tested this.

Two other options are 1. 1. Delete all DSP for the Mytek FireWire Zone. There’s a trace showing the Mytek disconnect from RAAT right after it loads the DSP configuration.
2. If that doesn’t work you can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Hello Daniel,
I’m happy to tell you that the recreation of RAAT-Server fixed the problem!
Thank you very much for your support an best regards.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.