Roon Server keeps stopping on Nucleus+

Roon Core Machine

Nucleus+ w/3TB
Version 1.0 (build 227) stable

Roon Server: version 1.8 (build 1021)

Networking Gear & Setup Details

10Gbe
Ubiquiti Unifi DreamMachine Pro
USW Flex-XG switch
Cat6 to Nucleus+

No VPN, no firewall

Connected Audio Devices

NAD M10 (wifi)
Sonos (wifi)
For troubleshooting,Macbook Pro via usb

Number of Tracks in Library

130k+ tracks

Description of Issue

Nucleus+ served media fine for months, never had an issue uploading tracks or connecting to to storage via smb

About 10 days ago i began having problems maintaining a connection.
The server stops abruptly once i start playing a track.
Any connection via smb is dropped
Roon remotes all spin and can’t connect to core
Accessing web console at http://192.168.1.127/ can confirm server has stopped
Can restart server but will disconnect again once music is playing

I have done hard and soft resets, re-installed operating system, tested with no wireless legs of the connection and confirmed this happens with all remotes and all devices. I have killed the orbitv3 folder and restarted. I have scrubbed through any similar support tickets for tips. Help!

how old is it… if under warranty (2yrs) contact the dealer you got it from…if thatw as Roon then @support is your best option.

could be the SSD is failing, support should be able to pull diagnostics if it stays up long enough

they dont work weekends so give them time to get this into view in their queue

Yep, it’s about 4 months old…i think i got it direct from Roon, but will double check

They should be able to sort you out then…I’m assuming its a Rev B unit, but could still be a faulty SSD boot drive / corrupted file system

Hey @Noah_Lopez ,

Thanks for your patience here while this reached my queue. I’ve enabled logging for your Nucleus and there’s definitely something interesting going on here.

I am not seeing any SSD issues, but you are getting frequent Out-Of-Memory errors, and the logs just end abruptly sometimes.

Even stranger, most of your logs end right when your Home Theater Apple TV is detected. Can you try to:

  1. Update to the latest Roon build via the Reinstall button in [Web UI] and check to see if the new build changes anything (https://help.roonlabs.com/portal/en/kb/articles/roonos-web) :

  1. Temporarily disconnect the Apple TV and notice if there is any change in behavior?

Let me know when possible, thanks!

Ok! Thanks for the troubleshooting tips, alas no dice.

I reinstalled the OS — i had done this previously, don’t know if i actually updated anything. Either way, connection still dropped.

Completely blocked that Apple TV from the network, but still lost the connection. I ensured there were no IP overlaps — they’re both connected via ethernet, to two separate switches and on different ip addresses.

Anything else to try? Any ideas why I’m running out of memory?

Hey @Noah_Lopez ,

Thanks for trying the OS reinstallation and blocking the Apple TV. I spoke to the team today about your case, and it’s a strange one for sure. Let’s proceed in the following way:

  1. Can you please upload your entire Roon Database to the following link? I want QA to load it up to take a look to see if this is a database-related issue:

https://workdrive.zohoexternal.com/collection/gnhz54df9ddffa33d49a3be8619bd6376a5de/external

  1. After sending the database can you please navigate to Roon Settings → Library and set Background Audio Analysis and On-demand Audio Analysis to OFF? This can help us confirm if Audio Analysis is triggering this behavior.

  2. I see that you have mentioned performing several resets, but have you tried running a bare-bones library on this Nucleus yet? I would temporarily set the current database aside and start with a fresh database and add only a handful of tracks to it, and this can further confirm/deny the database aspect:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database
  1. When I spoke to the team, it was mentioned that this is unlikely to be the actual RAM itself, but we should not rule it out completely as a possibility yet. If you are technically oriented, there is a tool called Memtest86 that tests your Nucleus RAM, there is a guide on how to use this below. If you have the know-how and can run the tool for 24 hours, this can help confirm/deny if there is a memory issue. Though, as I mentioned the memory might be fine and the issue is stemming from elsewhere.

https://www.memtest86.com/tech_creating-linux-mac.html

Hopefully, this helps but do let me know if you require any clarification on the above, thanks!

  1. database has been uploaded

  2. completed this step – player would still stop, but Roon Server would eventually restart and i could manually resume play. Typically I will often need to start Roon Server manually, don’t know if this is related or just coincidental

  3. I’ve been struggling to make a backup of my database since the server drops out and i have to redo again. I’m gonna assume that there’s something in the database upload I sent that i might be able to use…or the worst case scenario is that Roon needs to rebuild the database from scratch at some point.

Will test a clean db next

@noris i washed out the database and started brand new with only one folder of tracks in the Nucleus Plus internal storage – and it has been playing for over 10min now! What next?

I played my library for over 15 hours and it kept chugging along. I reimported my library into this database, checked for corrupt tracks, and started playing.

It lasted 36 seconds before disconnecting and has been sporadic ever since

@noris any suggestions?

Hi @Noah_Lopez ,

Thank you for running those tests! This does confirm that the issue is linked somehow to your database.

I took a look at the new log set and I noticed something interesting here, Roon tries to perform analysis on one file over and over again: /InternalStorage/Media/Diplo/Diplo & Friends/Diplo 08-20-2012.mp3

I wonder if this could be the cause of the memory issue, can you please move the file to somewhere Roon is not scanning (do not delete the file), reboot the Nucleus, and verify if the issue remains? Note, that if this file is causing the issue, I will kindly request a copy for QA purposes sent here:

https://workdrive.zohoexternal.com/collection/nqcgjac23027d90a441bda2c314de49d7958a/external

Thanks!

Hi @noris — i’ve been away, sorry for the silence. I removed that track, and still had issues. Reinstalled OS, rebuilt database, and then tried again. As I files were processing db, i was able to play for a good hour plus…but now that everything is set up again, i can only play tracks for a few seconds again

@noris checking in here – my nucleus plus is basically an expensive storage device right now :frowning:

@noris @support any suggestions here?

@noris @support should i just start pull my library off and start an RMA?

Hi @Noah_Lopez ,

Apologies for the delay in getting back to you here, things have been a bit backlogged since our 2.0 release. I did have a chance to talk to our QA team earlier today regarding your case and I do have some feedback for you.

This seems to suggest that the issue is media-related and not likely a hardware issue since the Nucleus works as expected without the full import of your data. Looking over your logs, it appears that there are a few issues with this folder: InternalStorage/No Media/

Is there any way that you can please temporarily move/exclude the No Media folder and see how Roon operates afterward? Please, do let us know if this helps!

1 Like