Roon server not installing on Synology DSM 7.0

I am not able to install RoonServer on my Synology DS916+ with DSM 7.0. I have done this before a few years ago in previous DSM versions, without any problem. Here is a snapshot of the error I am getting:

I‘ll take a look at the package for the cause.
Could you try rebooting your diskstation in the meantime and try again?
I have one situation in mind that might cause this, but can‘t verify it right now.

there is a nice tutorial on this forum to run Roon in a docker container on DSM 7. Walkthrough : Roon in a Docker container on Synology DSM 7

I use it too and it works flawlessly.

1 Like

Thank you for the quick reply Christopher and Niels.

I just restarted the NAS, tried again and still got the same error :frowning:

As for the “Docker container” option, I will try it if nothing more simple works :slight_smile:

Hi Christopher,

Do you think I should try the “Docker container” option? Don’t really know what that means but can try to follow step by step…


Anyone who can help on this?

Here is the walkthrough on setting up in a docker container. Though this was my first, I found it very easy on my 918+. Full credit to all those who put in the work. If you do go that route & have any questions, suggest you ask on that thread.

1 Like

thank you so much @Johnny_Ooooops and @Niels_Anders for pointing me in the right direction! :+1: :+1:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.