Roon Server not starting (DSM7)

I re-installed the previous version of Roon and install the beta version after upgrading to DSM7. However, Roon stopped the service automatically right after there service starts every time.
Can anyone guide me how to fix it?

Hi @Hank_Lee,
I have just noticed my old and first beta release for RoonServer for DSM7 was still linked in one of my post here. (I just replaced that link, with a link to my roononnas.org website) Can you verify, if you have installed the version, which is available on this website (20210809)?

1 Like

Hi @crieke,

The version I installed is 20210809. Any clue it happened this way?

Thanks a lot

Hank

ok, great!
Did you uninstall the old (DSM6) Roon Server before installing Roon Server on DSM7?
A direct upgrade without uninstalling the old DSM6 version first is not (yet) supported and might cause the issue.

Yes, what I’ve done is

  1. Upgrade to DSM 7
  2. Unload Roon 6
  3. Install Roon 7

I retried again and create a new share folder but it’s still not working…

Really appreciate of your patience.

Hank

Hey @Hank_Lee

I had the same problem. Roon was started and directly after that stopped.
I solved that problem by uninstalling and reinstalling Roon a few times. Not really a helpful solution, because I don’t know what the real problem was. But now Roon works as before and I am really happy.
@crieke: Thank you very much for your work! Really helpful!

Thanks @Felix_Susenburger.
I tried 10+ times but it’s still not working…

Hi, I am running DSM 7.0.1-42218 and just updated to RoonServer_Synology_DSM7_x86-64_20211105. Roon stops after a couple of seconds. Any idea…? Thanks for your support.

Hi Jochen,
Are you using the same shared folder (or usb-volume) for your Music files and the Roon Server database?

Hi Christopher, thank you for your quick response and … yes I am using the same folder.

Hi @crieke,
I just reinstalled the software from 20211105 using different folders for files and database. It seems to work perfectly now. Thank you for your work!

Hi Christopher, I’m having an issue after installing RoonServer_Synology_DSM7_x86-64_20211105.spk on my DS1819+ which is running DSM 7.0.1-42218. After installation, the app runs for about 15 seconds and the shuts down saying “manually stopped” even though I did not stop the app. Any suggestions? Thank you!

Hey @Felipe_Fernandez,

I had the same problem and sometimes the problem occurs again. In my case the problem is always that there is a second folder „RoonServer“ created which is empty. And the main RoonServer is in a folder named something like „RoonServer_1“.
If I delete the first one and rename the _1 then the RoonServer starts and runs without problems. But in some cases which I couldn‘t identify the same thing happens again. But always the deleting/renaming works for me.

Hi Felix, Thank you for your reply. After some more research, I found a post by Mr. Friedman on how to install Roon via Docker on DSM 7. I’m actually running another media server, Zappiti, on Docker and they both work flawlessly now. I’ll post a link to his post (I hope that he doesn’t mind - if so, please let me know and I’ll remove it. Walkthrough : Roon in a Docker container on Synology DSM 7

I had the same issue and found a workaround: add 120 seconds of delay after booting, before starting Roon. In that way, the usb share is available for sure once Roon starts. Unfortunately, I need to fix start.sh each time after an update. I posted this issue and the workaround a few weeks back, looking for a more robust solution.